Errors with the new Script Editor in Rhino 8

Dear all,

I have been trying the new C# Script Editor in Rhino 8, and let me tell you that it is quite awesome!

However, I keep running into a small issue: certain calls to certain methods in RhinoCommon cause a Error running script: Exception has been thrown by the target of an invocation. Examples are:

  • Calling the Mesh.Vertices.ToPoint3dArray() method on a mesh.
  • Retrieving the Mesh.TolopolyEdges property of a mesh.

And several other non-mesh related ones I have found… I have tried running running Rhino 8 in NETCore and NETFramework, and same error.

Has anyone encountered this issue?

Thanks!

JL

Nevermind, I just realized it was complaining because the methods were called on a null object.

So… perhaps a suggestion to improve the error message…? :sweat_smile:

Great work with the overhaul of the Script Editor anyway, feels so much better!

JL

1 Like

Hi, Jose Luis Garcia del Castillo.

I’ve encountered the same error. It worked fine in Rhino 7, but I’m getting an error in Rhino 8 with the same script. Could you kindly share how you resolved this issue?

Error image :

Rhino7 script :

Rhino8 script :