Error with Plugin

Hi,

I got this error when I installed plugin.
Could anyone tell me how to fix this?

Best,

Gen

I am currently working on fixing import_3dm for Blender 4.0 and 4.1. The API changed (yet again), which breaks the add-on. It will work in pre 4.0.

Hi,
Thank you for the reply.

pre4.0 means any version before 4.0?

Yes, I know it at least works with Blender 3.5

Hi,

Sorry but I had the same error.
I reinstall Blender3.5 and installed Plugin( import_3dm-v0.0.10-py3_9-macos-intel.zip)

Any way to solve?

Did you follow and read all instructions? For version v0.0.10 you need to restart Blender and then enable the addon again.

Yes, I did and I got this error.
I don’t know why.

Right, for Blender 3.5 you need the ZIP file with py3_10 in the name. If you’re on an Intel Mac that means https://github.com/jesterKing/import_3dm/releases/download/0.0.10/import_3dm-v0.0.10-py3_10-macos-intel.zip . If however you’re on an M1, M2 or M3 you need https://github.com/jesterKing/import_3dm/releases/download/0.0.10/import_3dm-v0.0.10-py3_10-macos-arm.zip, assuming you also have the Apple Silicon version of Blender 3.5

Thank you for telling the order, but I got an another error.

Looks to me that you should install the other version. If you used the macos-intel package on the first try use the macos-arm instead, and vice versa.

Okay, will do. Thanks for your patient and kindness.

Thank you so much Nathan.
It looks like the issue is solved.
I appreciate your kindness and support.

You’re welcome, enjoy Rhino and Blender :slight_smile: