Error When Trying To Launch Lands Design v5.3 and Rhino 7 & "Enter A Number" Error

I have uninstalled and reinstalled Lands Design v5.3 and Rhino 7 (most current release not beta or WIP) and when I click on the Lands Design (Rhino) desktop icon for first run I get this error message:
“No Rhino version has been found on this computer on which to run Lands.”

image

When I open Rhino 7 - Lands v5.3 is installed. However, if I try to change any of the parameters in the Lands Panel I get this error: “Enter a number.”. I am unable to change any parameters

image

I also have the latest version of VisualARQ v2.9 installed on an Alienware Area 51-M maxed out.

Any hints on what might be preventing Lands from working correctly?

Thanks.

I think the first problem is due to the change of the Rhino 7 folder name in Program Files (the sufix WIP/BETA has been removed).
Lands Design installation might be pointing to the old path. You can solve it by reinstalling Lands Design AFTER having updated Rhino 7 to the release version.

Regarding the “Enter a number” error, I remember a similar issue related to the Geolocation tab. It was fixed, but maybe it is now manifesting in a different way. Can you check the values in this tab?

Albert - I was able to fix the “No Rhino version has been found on this computer on which to run Lands.” error. By completely uninstalling Rhino and every plugin using Revo Uninstaller and checking for registry entries that had been left behind. So now double clicking on the desktop Lands Design icon works correctly and launches the Lands Design Rhino 7 Template.

I thought this may also fix the “Enter a number.” error. It is still there and I cannot do anything in Lands Design within Rhino. Here is a screenshot of the Geolocation Tab - it is set to the Miami area of the USA:

Is there anything else I can try? I need to use Rhino 7 as I have to take the design into Revit using Rhino.Inside.
Thanks

Hi @Darren,

As we cannot reproduce the issue on our computers, we need you to send us a dump file so we can check why this message is shown.

Please, reproduce the message “Enter a number”, and BEFORE pressing the OK button, open the windows “Task Manager” (press CTRL + SHIFT + ESC), then go to the “Details” tab, find the process “Rhino.exe”, right-click it and select the context menu option “Create dump file”. Then zip this file and send it to landsdesign@asuni.com. If the file is too large to send it by email, use a free service like WeTransfer.

Thanks,

Enric

One more thing: if you’re using Rhino.Inside.Revit when the message is shown, you need to find “Revit.exe” process name in the “Details” tab.

Enric

Thanks Enric - Just emailed you a Dropbox transfer link as the Rhino.exe dump file is 4.2GB. This is happening while just using Lands Design within Rhino. Everything I click within Lands Designs brings up this error.

Thanks you again for your always super fast support.

Thanks. We’re waiting for the file. Probably it will take some time, as it was pretty large.

Enric

Great - thank you. You have the link correct? You are just waiting for it to download from Dropbox?

I see, your drawing uses the Imperial units system. I think there is still a problem with the Geolocation tab, not supporting this units system. You can write numeric values on longitude and latitude fields (0 for example) to avoid the error message.
This will probably overwrite the 3dm localization. It’s just a workaround to let you keep working until a fix is released.

Hi,

No, we hacen’t received the link yet. Maybe the file is still uploading from your computer to DropBox servers.

Please, share the file to my email address (enric@asuni.com), as the other email account doesn’t have a DropBox account.

Enric

Okay - sent! I set all the Geolocation to 0. I tried also to switch from feet to meters in this panel but it didn’t make any difference. I did notice if I remove the " from the 0’s when I click back in the " is added back to the 0 even when set to meters. Is this the correct behavior or could this have something to do with it? I’ve also looked through all the settings in the options just to make sure there are no blank fields that might need a number. At the moment even if I click on a Lands Design object and click off it without making any changes I get the “Enter a number” error.

As a test I switched the entire model and layout units to meters and the error disappears!

If I then try to enter the location and use the 25’9-9/32" in the latitude I get the error - so it is definitely the translation from Scientific units to Imperial. Hope this helps!

Yes, Lands is converting latitude and longitude degrees to imperial, which has no sense at all and produces the error. If you need to work in imperial, select in the geolocation tab the “Decimal degrees” format (instead of “Degrees, minutes and seconds”) and set all values to zero. This must work. The other option has three values linked making harder to cheat the imperial system units used.