Error loading rhino file to revit with RIR

Hi - Any idea why when trying to import a rhino file into Revit with Rhino.Inside I get an error that says the following (and fails)?
“error cannot be ignored”
“name cannot include prohibited characters.”
“Parameter name: name”
I have tried renaming my Rhino 3dm file with no luck. I have the latest build of Rhino.Inside and am running Revit 2021.

How are you importing exactly? What type of elements are you creating? Thanks.

Was trying to just use the import 3dm tool that is available in the rhino drop down (rather than using grasshopper). In the past I was able to do this and the model would come into Revit as generic mass but retain color/texture map attributes.

Ok, There maybe a improper character in the layers or object names. What language are you working in?

If you can post or send me the file i can take a look.


I have underscores and dashes in my layer names - are there specific characters I cannot have in my layer names? Thanks!

see below

\ : { } | ; < > ? ` ~ [ ]

nope - don’t have any of those in the layer names or file name

object names?

Hi - no, no object names, all blank

Uploading the file. I’ve tried everything (renaming layers, renaming file, etc.) but no luck. Cannot use the straight RIR 3dm import. Keep getting the error about illegal characters. I have no trouble using the grasshopper RIR import process but am trying to save time with the one-button 3dm import command without grasshopper. I tried a different model (simple cube) and it worked fine. Something about this rhino file is problematic. Thanks

1 Like

The [ ] brackets on a Material Name, sorry not on the list (added it to the list)

Where are you seeing those brackets? My material names have parenthesis such as plaster (1), but not brackets. Thx

Sorry, found one case of brackets on a material. Will try removing and testing. Thanks.

1 Like

Nope - still doesn’t work, same error:
dname cannot include prohibited characters.
Parameter name: name

Could this be because the material names have parenthesis? I removed all brackets.


No, this worked for me, i even double checked it with your file. Removing the Brackets and Saving worked. The other variable here is the save. What version of Rhino & Rhino.Inside.Revit are you on?

I’m on the daily build. I’ll try it with just the save this time.


Just ran it through the paces again. It fails after a save and no change, i change the name of the material and save and it works.

Yep - I did that and it worked. Thanks for your help.