Error importing STL

Rhino 7:

Currently unable importing or opening an STL files exported just moments ago.
Opening the STL files in Rhino 7 is possible without error but the result is an empty file.

The STL files can be opened and imported in Rhino WIP successfully. No problem whatsoever.

The file below is for testing and originally was a SubD.
The problem also occured with three other more complex shapes, which are all closed polysurfaces

test_export_stl.stl (2.0 MB)

System Info

Rhino 7 SR10 2021-8-11 (Rhino 7, 7.10.21223.07001, Git hash:master @ a594cb4449602d6cce40b57e3359213e6441c15f)
License type: Kommerziell, build 2021-08-11
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) HD Graphics 630 (Intel) Memory: 1GB, Driver date: 10-7-2019 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro P4000 with Max-Q Design (NVidia) Memory: 8GB, Driver date: 4-12-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 466.11
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Secondary monitor attached to adapter port #1

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 4-12-2021
Driver Version: 27.21.14.6611
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

Rhino plugins that do not ship with Rhino
C:\Users\martinsiegrist\AppData\Roaming\McNeel\Rhinoceros\7.0\Plug-ins\KeyShot9RhinoPlugin (ecfe8d1f-876a-460f-aa5e-3dd816936811)\1.0.0.0\KeyShot9RhinoPlugin\Rhino 5.0\KeyShot9RhinoPlugin.rhp “KeyShot9RhinoPlugin” 1.0.0.0

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.10.21223.7001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 7\Plug-ins\export_STL.rhp “STL Export”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.10.21223.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.10.21223.7001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.10.21223.7001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.10.21223.7001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hello - the file opens here in 7 - I will install the build you have and test that.

The file opens normally, here, in 7.10.

I guess you should close and restart Rhino from scratch, and if that does not sort it out, do a repair on the installation and/or try with the Keyshot stuff all disabled, one never knows.

-Pascal

-Pascal

Thanks for your reply.

I disabled all plugins that don’t ship with Rhino and installed the latest build from today but this did not have any effect on the problem.

The import error must be something recent.

Also I mentioned I was able to import in Rhino WIP without any problems