C++ First plugin


#1

Hi,

I started following tutorial for rhino first plugin in C++ :

I managed to build the project, but when I load test.rhp file to rhino beta I get error window:
Unable to load Test.rhp plug-in: initialization failed.

Can someone guide me through this process to build the first plugin correctly?

What I did:
I downloaded and installed required C++ assemblies, then created new project with template and deleted #error Developer declarations block is incomplete!

I attached screenshots:


(Dale Fugier) #2

Hi @Petras_Vestartas,

Make sure the version of Rhino 6 is greater than or equal to that of the version of the Rhino C/C++ SDK that you are building your plug-in against.

Also, if you don’t want to see all of the Intellisense errors, then just change the view in the Error List window.

build_errors

– Dale


#3

Dear Dale,

Where can I see sdk and rhino 6 version?

I have updated rhino 6 beta last week, and downloaded sdk today.


#4

I installed sdk on other computer and test plugin is build and loaded to rhino without errors.
But on mine it is still not working.

Tomorrow I will try to update rhino 6 beta and sdk.

For sdk C++, should unistall previous version, or it is enough to run downloaded install file?


(Dale Fugier) #5

Open and review version.h found here:

C:\Program Files\Rhino 6 SDK

You can just install over the top of the the previously installed version. But there shouldn’t be a reason to download a new SDK. You should, however, download and install an updated Rhino 6 Beta.

– Dale


#7

Dear Dale,

I updated rhino beta and and sdk, but still on one computer I get that error message when installing plugin in rhino while on another it works.

Do you have any ideas what went wrong?

Is it possible somehow to debug this error why it is not loading?

version

error


(Dale Fugier) #8

Hi @Petras_Vestartas,

Not off the top of my head. Can you post your plug-in .RHP file so I can try to load it here?

Also, what version and service release of Visual Studio 2017 are you building with?

Thanks,

– Dale


#9

Thank you for the reply. It is finally solved and I would explain what was causing this issue:

It is probably C++ specific (if you know why please explain)

In my office pc I have 2 drives C and D drive. I was writing visual studio projects to D drive.
I took my laptop home and tried to create new visual studio project and this time visual studio complained that I have no permission to use debugger on D drive. So I simply change directory of project to C:/VisualStudioFolder created test plugin there. Loaded in rhino and it works.


(Anna) #10

Hey,

I’m facing the same problem. I tried to migrate my c++ plugin from Rhino 5 to Rhino 6. It compiles but i cannot load it. I already checked the version numbers but they are the same.

grafik
grafik

My C# plugin works fine and if I compile the Rhinotemplate provided by Visual Studio, it also works. I’m using VS Version 15.5.6.

Has anyone an idea what could be wrong?


#11

In which location of your pc you are compiling your code ?

In the end I created folder in C:/MyLearningPlugins and it loaded well then.


(Dale Fugier) #12

Hi @am.bauer,

If you create a new plug-in project, does it build and load?

When you migrated your plug-in source from V5 to V6, did you follow the migration guide?

Any addition details may be helpful.

Thanks,

– Dale


(Anna) #13

It is located in C:/carat/PlugInfolder.

The new project, following the instructions, builds and loads in Rhino.
I tried also to follow the migration guide, but I could not find the pseudodebug in order to rename it. But what I understood this is just a release version with debug information, so this should not affect the release compilation, should it? However, my plugin builds for release.

The PlugIn structures itself is more complex than the template as it has several subprojects.

Are there any other details which might help?


(Dale Fugier) #14

Hi @am.bauer,

Without the actual project, there isn’t much I can suggest (other than to dissect the project source generated by the plug-in wizard.

– Dale


(Anna) #15

Ok, thanks anyway!