Environment won't refresh with new file

As you see I have trouble to get rendering going with raycasting/cycles. Where do I have to change the hdri images for cycles render and render viewport?

Also where are the Rhino environment hdri files gone (thought there were many in Rhino 6.

Thank you!

Hi @hannesgrebin
Without going too much into the complete mess that environment handling in Rhino, the easiest way (in my book, that is) is to right click on the environment and select “Set as global environment”.

.
The settings for which specific environment does what can be fine-tuned in the Rendering tab (and notice that viewport modes can override the background setting, so also check the Display tab, if you are having problems).
The pre-set render environments are in:
…:\Users\USERNAME\AppData\Roaming\McNeel\Rhinoceros\7.0\Localization\en-US\Render Content\Environments on Windows, no idea for Mac, sorry
HTH, Jakob

Thank you @Normand

Rendering in Rhino could be more adopted if it would work easily.