Oct3 Rhino and Cylcles Render the wrong rotation of environment map

In the oct 3 wip, both Rhino render and cycles are not showing the environment maps rotation in the rendering but default back to some standard view. In the last wip it was only cycles that did this but now in the current wip it’s in the Rhino renderer too.

Can you please upload a file that shows this? According your screenshot you don’t have a rotation set (Azimuth and Rotation both show 0.0deg)

It has nothing to do with the environment map settings, it has to do with simply rotating your view and rendering when an environment map is on.
Apply an environment map, in perspective view rotate your view and hit render
notice that the rendered image is completely different than what you are seeing in the perspective view. What you see in my image above is the perspective view and its rendered window side by side notice they don’t match or show the same view of the environment map. This is both in cycles and rhino render.

Do the environments match between Rendered and Raytaced?

This is what I see with Raytraced left, Rendered right:


Not in the viewport nor in the cycles viewport it happens when you hit the ! _Render button.
The view of the environment doesn’t match as you can see in the image I posted notice one is the render window you get by hitting or typing the render command and the other is the viewport.
In your image you have two viewports I’m talking about the ! _Render command.

Looks fine still to me.

Make sure you are rendering the correct view. You’ll notice a new section called View below the renderer:


Perhaps you have a different view specified to render from?

After fiddling with it I found you are correct Rhino seems to work as expected when I create a new file, but I narrowed it down to this file. Notice in the image the environ map doesn’t match, I created the file before Oct 3 wip maybe a setting somewhere? I’ve attached the file stripped down to a cube with environ map.
Thanks for your help on this and for your attention to detail.

EnvriMap.3dm (5.6 MB)

1 Like

The problem is the altitude in the texture. It looks like the direction is flipped indeed.

There are several problems here:

  • input and output projection are both set.You should set to Same as input, and the input as it is (Equirectangular)
  • altitude in the texture isn’t supported well, as
  • UV-mapping isn’t properly converted yet

I have logged YT issues as RH-41782, RH-41783 and RH-41784.

For now you’ll have to stay clear of the input/output projection changes (even if they are the same, just ensure output is set to input, and input to Equirectangular), and not fiddle with altitude and mapping. Rotation should work fine.

Thank you for reporting.