Environment materials suddenly go black latest V6 build

This only started with the last public release of V6
I have environment materials in my models; what happens is they just suddenly go black for no apparent reason. Other instances of V6 are not affected.
Saving the file seems to bring them back; if not, closing and re-opening sorts it out till next time.
Not very helpful sorry - it just happens in an instant for not discernible reason…


Rhino 6 SR29 2020-8-25 (Rhino 6, 6.29.20238.11501, Git hash:master @ 06b936ae4e8c289ecccfd6b5ee9bacccc60eded1)
License type: Commercial, build 2020-08-25
License details: Stand-Alone

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)
Machine name: DESKTOP-PB658NV

Hybrid graphics system.
Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 5-19-2020 (M-D-Y).
Primary OpenGL: NVIDIA Quadro P3200 (NVidia) Memory: 6GB, Driver date: 7-13-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 451.77

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 7-13-2020
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins
C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.29.20238.11501
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi Rabbit - how many Rhinos are running? Can you tell if it makes any difference if only one is running, or multiples?


Hello Pascal

Usually one other, sometimes three, sometimes just one…
It doesn’t seem to make any difference…

Hi Rabbit - ok, thanks, I’ve asked one of the developers to weigh in.


have you set your machine to use the nvidia for rhino?

my guess is you are set to run on then intel, are running out of vram and rhino is pooping it’s pants because of that.

see and do this-


I’m a little confused here…

Rhino 5 reports in options / OpenGL that the nvidia card is running the show, no mention of the intel.

Rhino 6 & 7 show exactly the same info:

Hybrid graphics system.

Primary display: Intel® UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 5-19-2020 (M-D-Y).

Primary OpenGL: NVIDIA Quadro P3200 (NVidia) Memory: 6GB, Driver date: 8-12-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 452.06

All the rhinos run like they have plenty of room, are fast and stable - apart from two problems:

1] as reported above, V6 will randomly and suddenly lose environment maps.

2] As reported elsewhere, V7 has started losing the ability to highlight 3D objects when selected in render view. Its fine for a while, then is just suddenly refuses to play nice.

The objects are actually selected (as you can see in other views that are not in render mode).

This is what things were like before I changed the windows graphics settings to use “High Power” as per your instructions.

Now, the windows graphics window has listings for V5, V6 and V7 as “High Performance”

But, in V6 and V7 the info in system settings is exactly the same as before - ie the Primary display is intel, the Primary openGL is Nvidia.

So not only does there appear to be no change, but it seems this machine was already automatically using the nvidia card for rhino in anycase…


ok, with hybrid machines this is the 1st thing we check to make sure it’s not a hardware issue.