Enter-key not recognised (in Rhino 5 for Windows)

I am having this escape key issue as well. Can’t cancel any commands or stop displaying points by hitting escape. shift-! does work though.
I can’t isolate a reason (file, command, script, etc.) It used to be random, and fixable with a rhino restart, but now after upgrade to:
Version 5 SR10 64-bit
(5.10.41201.11145, 12/1/2014)
a rhino restart is not fixing it.
Anyone have any new info about this? I don’t have GH running right now either.
thanks,
R

UPDATE: I found this info about photoshop causing key mapping issues when running in the background.


Further down the page people are talking about some other things that might be the cause (intel/nvidia graphics yaddayadda, etc)
Maybe something that helps some of the above posters…
For me, closing my cs3 solves it. Also, shift-esc is recognized by rhino for those times I need photoshop open at the same time.

Yep, same issue for me… No escape key in Rhino, and getting message “An installation of Stratasys Insight software cannot be found.”

Using grasshopper… but haven’t baked anything.

I have also been running Revit at the same time?

Simply restarting Rhino has fixed it for me this time :smile:

Yes, I keep getting the same error and I am stuck. I do not have “Dimension Catalyst” installed.

What to do?

Same here, baked a component, and now I get all these messages.

Screenshots, while pressing Esc, Space and right click.

I just had the same issue for a couple of times in a row.
After the Grasshopper bake, Rhino reports the following message in the command bar:

An installation of Dimension Catalyst software cannot be found.

Indeed the problem goes away with Rhino restart, but doing this after every Grasshopper bake is a little bit annoying.

I am using Rhino 5 SR12 64-bit (5.12.50810.13095), and Grasshopper (0.9.0076).

Will this issue not be solved in Rhino 5?
Will the bug be fixed only in Rhino WIP/6?

I can confirm that this is still happening with Rhino 5 SR14 (5.14.522.8390) and Grasshopper (0.9.0076) after baking something from Grasshopper. Not all the time, but often enough to be super annoying.

Have we ever gotten a reply from someone at McNeel or Grasshopper? Is this ever going to get fixed?

Does this happen in Rhino WIP and its Grasshopper too?

Not sure, as I am not using the Rhino WIP. It also doesnt happen all the time, so I cant really test it.

Did you change anything in the WIP that would affect this behaviour, ie. did you ever find the reason for it happening?

I think that a bug isnt fixed unless you actively tracked down the cause of it and changed something so it doesnt happen any more. Or is the Rhino WIP so fundamentally different to 5.14 that it might have magically fixed itsself, if that wasnt the case in the last updates to Rhino 5 for the last 3.5 years and possibly more?

Lots of changes have happened for both Rhino and Grasshopper. There won’t br any further service releases for v5, so best is to start testing the WIP.

Since the problem happens reportedly only on an intermittent basis it will be difficult to replicate.

I think @DavidRutten is aware of this, not sure though. In any case it’d be good to give the WIP a good spin, all the developer effort is there.

I understand that completely, but 3.5 years ago version 5.14 would have been the WIP (or probably even an earlier version_ at the time and nobody ever seemed to have tried to fix or understand it, even though lots of people have given repeatable examples in this thread.

I am just trying to understand why that is and if anyone ever DID look into it and what they found. Seems like a reasonable request and a serious enough bug to be looked into.

Yup, this problem goes back nearly a decade. I have been unable to get anyone who understands the way Rhino deals with keyboard input to take a look at this because I have never gotten a 100% reliable-press-this-button-once-to-repeat scenario.

Baking is heavily implicated, but I have seen it happen without as well. On my machine the symptoms are that RBM, Enter, Escape and Delete stop working, but I can still run commands by pressing the space bar after typing them. I actually don’t remember seeing this lately, so either I’ve subconsciously learned to avoid doing the one thing that causes this, or it’s been fixed by happy coincidence in RhinoWIP, I’m no longer doing the things I used to do a few years back, or my memory simply isn’t recording this any more.

Thanks @DavidRutten, same here. It just happens sometimes, but I cant reliably repeat it, although someone in this thread says he has a repeatable example. But I guess its only repeatable on his machine and not everywhere.

It has happened on all our machines here at some point, so it seems like its some definite chain of events leading to it.

Such a weird bug. Does Rhino keep some sort of log of what it does, so that next time it happens we can have a look at what happens just prior to this happening?

yup… this thing is still happening. Is there something users can do to help? Any test we can run once it happens to help analyze the cause? I can confirm that this latest time it happened with a relatively vanilla GH script that involved no baking.

I’ll ask if there’s something we can do on our end to gather a bunch of information that might help us see why these keys stop responding.

I encountered this problem in Rhino 7 yesterday. was doing research couldn’t find a solution.

Enter, delete and escape keys don’t work but everything else is fine

Today I solved it. It’s because there is a pop-up message hidden behind all rhino windows at launch. In my case it’s from a plug-in. Because this window automatically gets covered by rhino itself it remains unnoticeable.

you have to navigate through window’s bar and manually close that window then all the keys are back to normal

You should probably inform the plug-in creator of the problem and ask them to fix it.

I have been having this same problem (Enter, Escape, Delete, Backspace, Right Click stop working randomly) since Rhino 5. Currently on Rhino 7, still happens occasionally. In my case it seems that it always happens following the completion of a python script. I have experienced this issue in version 5, 6, 7, on at least 2 different computers. When upgrading from 5 to 6 I thought the issue was gone at first, but it seemed like the occurrences were just fewer and farther between. Now in ver 7 it feels like it is happening more frequently again.

Extra note: these problem keys still work while typing in textboxes in Rhino, but they don’t execute their expected functions in the drawing windows. Delete and backspace still delete and backspace over characters while typing, but they don’t delete selected objects.

When this problem crops up while I am in the middle of a command I need to complete, I use “Control M” to simulate the Enter key, which works and lets me finish that operation. However, this sometimes also immediately executes “’_MaxViewport” which changes the viewport.

Hello - I ran into the delete key failure today, while messing with Python in the editor - does it happen in your case just running a script apart form the editor as well?

RH-63476 Python script editor: Enter key stops working

-Pascal

1 Like

I almost always have the Python editor open, so from memory I’d say all of the time it happens after running a python script from the editor. But I can’t be 100% sure.