Elefront Bake All issue

The issue is still here in V7.
It happens here with the “Bake” component.
A “trick” that seems to be working is to intersperse a METAHOPPER “Enable / Disable component” between the actual trigger and a “true” boolean serving as a trigger.

I know this is a little OT, but it’s about these pesky components that don’t have a trigger input, but only have a button on them.
It’s the case with “Reference by Bakename”… I’m trying to use it to delete the blocks that were created during the bake, as my goal is not to create instances, but simply to update their definition.

Human allows to just update a definition, but it doesn’t want points as part of the block content :frowning:

1 Like

this option controls the refresh/not refresh (disable auto update)


I failed to notice that. Thanks !
Now I need to figure out how to delay the trigger do that I can delete the block instances when they are all created…

Why do we have to bake these darn “Define Block” components ?
Allowing to just modify block definitions without creating instances seems so evident…

Could there be a C# component lying around that would do just that ?

Pancake’s True-only Button probably helps with the freezing issue, and Wait Until to control the logic flow. I’m not sure.

But eventually, the all is caused by the swamp of Grasshopper manipulating blocks… :crazy_face:

Anyhow, Metahopper saves the day again.
The same trick works also to delete the unwanted instances.
I don’t know how, but the timing works each time (for now) :

Well, it works, but the problem is that I don’t want a GH button : I trigger things through Human UI.

All this would’t even be an issue if I didn’t have to delete those pesky instances…

PS : the “WaitUntil” component is really cool

:crazy_face: that’s the reason I’ve been using scripts to modify blocks

though that’s not quite the way of using those 2 components… You don’t need MetaHopper IMO

Well, if one of these scripts could fall off the truck, I’d be glad to pick it up

1 Like

Here’s another possible option, if you wanted to wait until after all the blocks are made. and want to skip the added click on the Reference by BakeName. Basically adding something that will trigger once the Bake component completes its solution.

Duly noted on being able modify embedded blocks without having to bake. Will see what I can do about adding something like that for the next release, though that’s a couple months away.

1 Like

I happened to be testing just that:
createblockdefinition.gh (4.3 KB)

seems to create definitions in the Rhino doc without instances

1 Like

…except there’s no “attributes” (Rhino properties + User texts) input :

indeed…I haven’t yet figured out how that works :grimacing:

I’m afraid that, in order to add attributes to objects, they first have to be created in the Rhino doc, so no dice:


looks like this starts to work:
createblockdefinition.gh (13.8 KB)

1 Like

Cage 22 :smiley:
this is also what frustrates me that great plugin is sometimes limited by something like this. thats why i think there should be some kind of certification of plugins so they follow some GH “code” (all components with embedded buttons must enable the same functionality with input, …)

I am having trouble to get data from .xls because there are maybe 4 plugins doing that but each has stupid limitation. One cannot deal with columns past Z (input is in form of only ONE letter). Another cannot load files offline (you need to have xls opened in excel). So on and so forth.

We need more native fully functioning components for basic stuff. (blocks are not basic since its not natively supported in GH, but maybe in G2?)

@DavidRutten is it a bad idea? Policy not to kill plugin developers but standardize things a bit instead with motivation to get GH certification

Thank you for this!

hi @krahimzadeh ,
This problem started to happen to me too. When I bake the blocks with the button, the gh canvas freezes. I have to press the button again to solve the problem.

not sure if this solve your problem but try to click and hold the button instead. If it does, the issue was clicking ‘too fast’.

First of all thank you for your reply, I tried your suggestion and it solved the problem.
But the fact that this issue is specific only to these components, I still think that it is a problem that needs to be investigated.

It’s a well known issue (the button, not bake component) for 10+ years so yeah not much hope to get it fixed unfortunately.