Edges Fillet error



I’m having a problem with the filletedge cmd, i can’t understand what is happening.

I already tried in rhino mesh options to custom the minimum edge length to 0.00001 and it won’t make any good.

Thanks in advance.


Looks like the FilletEdge command failed. That is pretty common. Post the geometry if you want more input.


Thank you for your feedback.

Well it is an extrusion of this section for an escalator. The curve is closed.

(Pascal Golay) #4

Hi Laurenco - check the continuity of the curve segments, assuming it explodes into pieces - make sure that segments that should be tangent are in fact tangent (GCon command). The curvature graph can also help locate suspicious areas of the curve. Please post the curve itself in a Rhino file if you do not get it sorted out.



Hi Pascal,

I can’t figure it out.

I’ve tried to redesign the curve but it won’t solve my problem when i try to fillet edge.

Please find the rhino file attached.

Thanks a lot.

CURVE FAILURE.3dm (156.2 KB)


Your technique for connecting straight lines with arcs is producing small tangency errors which causes the filleting to fail. Use the curve Fillet command to connect two straight lines with an arc segment. Fillet will do it correctly with no tangency errors.

The easiest way to determine where your arcs are not tangent is to examine where fillets are failing. Mark those locations using dupborder and then delete the failed geometry and go back and replace the arcs in the curves where failures occurred with curve fillets of the same size. Then try the extrusion and filleting again.
FixedCurves.3dm (164.0 KB)