Don't want points to display

unhandled

(Joe Babb) #1

I keep working on my scroll program and have it working so that I can flip the scroll around and resize it and control its growth. I want to draw the scroll using the interpolate curve function and I have that working. But it also displays the points that were created and I don’t want that. I only want the curve to be shown. my-scrolls.gh (12.5 KB)
Can someone show me how to turn off the points? Did I use the wrong point block or ??
thanks
Joe


#2


turn off preview on everything and feed the output curve into a collector
to turn off preview right click on a component and there is a check mark you can uncheck called preview


(Joe Babb) #3

Thanks very much Will. Just turning off the preview on the Point object worked. But I’m still learning GH slowly. You used the term “collector” which I see labeled Crv in your image. What is it and is it necessary or good practice?


(Joe Babb) #4

Well, just turning off preview on the Point object worked until I baked it into my drawing and the points showed back up. Will the collector prevent that?


(Tim Stark) #5

You mean like this? Both are your curves baked. The front is selected. The Points you see there, are the control points of the curve. For example you can click on them and move them to edit the curve. You can turn them off with “PointsOff”


(David Rutten) #6

“Collector” is not standard nomenclature, but it is descriptive of the usage in @Will_Wang’s case. Typically these objects are called “Parameters” and their primary function is to store data. The inputs and output of components are also parameters, they just happen to be attached to a component.

If a component is showing a lot of previews and you want to limit it to one or two outputs only, you can hide the entire component and funnel the wanted data into individual parameters. This gives you a more fine-grained control over what to preview and what to bake.

Preview=off will not prevent baking from happening. You have to select those components you wish to bake, so just omit a component which contains data you do not wish to bake before pressing the Insert key.

It also sounds like you were surprised that certain points still showed up in the preview. Grasshopper never modifies data, it always keeps the old data and creates modified copies. So if you move or rotate some geometry, the original geometry is still there, but now you also have transformed geometry.


(Joe Babb) #7

Thanks for that explanation, David. First question is what are those “parameter” objects and where are they found? Will only showed an image and I could not use that to find the object he used.
For the rest, this shows how much I don’t know about GH. In my first attempt to bake a scroll I had, or thought I had to select everything. I did not realize that I could select only the Interpolate Curve and bake its data. Is that correct? I do not understand your comment about the “Insert” key.
I continue to be frustrated by lack of documentation that I can go to in order to learn. Without this forum I would have given up on Rhino6 and GH and just stuck with Rhino5 which is still not easy to learn on your own. I’m not a dummy. I’ve got 35+ years of programming experience as an engineer. But when I don’t have documentation or don’t know where to find it, it gets very frustrating.


(Joe Babb) #8

Hi Tim.
No I understand control points. These “extras” where from the Point object immediately preceding the Interpolate Curve. David has explained below how I can bake only the Interpolate Crv object and that seems to work.
Joe


(David Rutten) #9

you can bake individual objects via their menus, or you can just select a bunch of them and press the Insert key on your keyboard. It’s a shortcut for insta-baking.