DisplayConduit wont turn off? (Solved_EBKAC)


#1

hey there, sending conduit.Enabled = false; does not turn off the foreground drawing, even re initialising the conduit with a null string wont get rid of the text?

What am I missing?


(Giulio Piacentino) #2

In which version of Rhino are you seeing this?

Thanks

Giulio

Giulio Piacentino
for Robert McNeel & Associates
giulio@mcneel.com


#3

5.13.60523.20140


(Menno Deij - van Rijswijk) #4

After calling conduit.Enabled = false, you should call doc.Views.Redraw() once more to force an update of the views. Otherwise, they will keep showing the last frame drawn.


#5

nope, no go either… even file/new doesn’t kill the conduit… this home version is 5.13.60523.20140 also.


#6

you no where replace conduit with a new conduit?


(Menno Deij - van Rijswijk) #7

Looking at the code, I see more than one way the command is exited (return GetComOption.CommandResult()). Please verify that you reach the execution of the Enabled = false!


#8

@jordy read the whole thread, initially i tiried recreating the conduit, then initializing the conduit with new string as well, neither worked.

@menno, after i exit the while(true) getcompoption and the user has finished, the first command outside the loop is conduits enabled = false, if it wasnt reaching that it wouldn’t be reaching the return result.success either. for fun ill set a breakpoint to check it.

BRB


(Steve Baer) #9

Menno is referring to the return statement on line 122 in your video. That return statement would keep the conduit created at the beginning of the function around forever.

This seems pretty easy to test in the debugger to make sure line 180 actually gets executed.


#10

ahhhh. ok. got it. trying to fire up over remote desktop to test (slow as molasses) but it makes sense.

edit: Perfect, that fixed it up. the dangers of tab-tab snippets…