Display turns black - what's going on?

Wireframe - normal
Shaded - normal
Rendered - BLACK
Ghosted - normal
X-ray - normal
Technical - BLACK
Artistic - normal
Pen - BLACK
Arctic - BLACK
Raytraced - BLACK

Just updated drivers, no change.
Turning skylight makes no change.
I can bring display to life by turning OFF some layers, but it is not a solution.
It seems like there is limit to elements Rhino can display.

System info:
Rhino 6 SR14 2019-3-26 (Rhino 6, 6.14.19085.9141, Git hash:master @ 5735fd2f55500f5781f40c02b70d7bc0d57d6e4d)
License type: Commercial, build 2019-03-26
License details: Cloud Zoo. In use by: Piotr ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DESKTOP-BNUR9UE

Non-hybrid graphics.
Primary display and OpenGL: Radeon Pro 555 (AMD) Memory: 2GB, Driver date: 7-20-2017 (M-D-Y). OpenGL Ver: 4.5.13476 Compatibility Profile Context 22.19.170.1536

OpenGL Settings

  • Safe mode: Off*
  • Use accelerated hardware modes: On*
  • Redraw scene when viewports are exposed: On*
  • Anti-alias mode: 8x*
  • Mip Map Filtering: Linear*
  • Anisotropic Filtering Mode: Height*
  • Vendor Name: ATI Technologies Inc.*
  • Render version: 4.5*
  • Shading Language: 4.50*
  • Driver Date: 7-20-2017*
  • Driver Version: 22.19.170.1536*
  • Maximum Texture size: 16384 x 16384*
  • Z-Buffer depth: 24 bits*
  • Maximum Viewport size: 16384 x 16384*
  • Total Video Memory: 2 GB*

Rhino plugins

  • C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.14.19085.9141*
  • C:\Program Files\XirusCAD\1.0.1.3\v6\Xirus.rhp “XirusCAD” *
  • C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser” *
  • C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit” *
  • C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript” *
  • C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools” *
  • C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor” *
  • C:\Program Files\Common Files\McNeel\Rhinoceros\6.0\Plug-ins\CreateQuadMesh (5bf6c0f3-3657-4ad5-834a-bbbb52706a40)\6.0.6914.24116\CreateQuadMesh.rhp “CreateQuadMesh” 6.0.6914.24116*
  • C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render” *
  • C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.14.19085.9141*
  • C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI” *
  • C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots” *
  • C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter” *
  • C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.14.19085.9141*
  • C:\Program Files\Rhino 6\Plug-ins\Grasshopper\GrasshopperPlugin.rhp “Grasshopper” 6.14.19085.9141*
  • C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.14.19085.9141*
  • C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse” *
  • C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement” *
  • C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc” *
  • C:\Program Files\Rhino 6\Plug-ins\NamedPositions.rhp “Named Position”*

Hi Piotr, from your other post today…


… can I assume that this is new behavior on your system?
What has changed?

@jeff is looking into some blackness in another case, perhaps he has more questions or answers…

Nothing has changed, I have made the test on all display modes to check the behavioral pattern.

Just installed evaluate rhino SR13 on standalone workstation. The same problems appears.
You can rule out the hardware problems.

Black generally indicates an OpenGL display problem.
The drivers for your AMD Radeon are a couple years old.
I would start with a driver update.

Can I get the example and steps you’re using to reproduce this… If you’re able to reproduce this on two different systems, then most likely it is a Rhino problem…and most likely we should be able to reproduce it here…which means we’ll also be able to fix it…so the more details you provide, the better chance I have of seeing the problem.

Thanks,
-Jeff

Nope, no limits… It’s more like there is something specific about the objects (materials, meshes, etc…) that is causing the display to do wonky things. Again, getting what you’re using is the best way for us to try to reproduce it…

Does this happen immediately upon loading the file? Or does it take a while of usage before it starts happening?

-J

Hi Jeff
As usual, I will send it to tech, adressed to you.
There is, clearly something to do with the number of elements.
As soon as I reduce the number elements on the scene it starts displaying them, and I am talking about various layer combinations, so, mostly, no material-related.

I don’t want to be too quick to judge here, but looking at your plugin list I see XirusCAD and CreateQuadMesh, which are both relatively new and thus potentially more suspect than the others. Have you tried without them?

Diasbled, restarted, didn’t help.
XNurbs can also be ruled out.
I have QuadMesh installed for a while, never caused this behaviour.

Another interesting issue:
when some nurbs objects are replaced with mesh the Save Display preview turns black.

FYI, XirusCAD != XNurbs.

Thanks! Got the file…

And as usual, everything is working fine here…even with all layers turned ON… I’ve tried all display modes too…they work as expected… Ugh… this means that finding this one now is going to be a lot more difficult. …still looking, but I’m pretty sure though that this is not an “object type” issue… I’m currently trying to find an AMD card here that has only 2GB. Given your scene and file, that should be plenty…but I want to try to get a system here configured to something as close as possible to yours. How many monitors do you use? What resolutions are being used?

By “turns black”, do you mean the entire viewport goes black? Or certain objects turn black?

Also, please try these one at a time…

  1. Once things go black, does it remain black for any/all view manipulation? (i.e. Zoom, pan, rotate…) don’t turn anything On of Off, just try things that only act on the view and camera… Try doing something like SelAll followed by ZS (zoom selected)… Are you able to get rid of the “blackness” doing such actions? (EDIT: Also try maximizing and restoring the viewports as well as Rhino’s main window)

  2. Once things go black, save the file, close Rhino. Now start Rhino and load the file you saved…are things still black?

  3. Once things go black, are there any display mode settings you can make that brings it back? Note: This is not things like SkyLight or environment settings… I’m only talking about the settings found in the Display Settings pages for a given display mode…and also found in the Display panel tab. Also, are all display mode settings at their defaults when the blackness occurs?

  4. Are you using any kind(s) of command(s) that alter the appearance of your views? This would be things like the GradientView command, which changes how the background is drawn/rendered. If so, does turning it/them OFF (undoing whatever it is they do), bring things back to normal?

WARNING Please make sure you have a backup of your file before doing the next step…
5) If you do a “SaveAs…”, and only check the “Save geometry only” option (i.e. uncheck everything else, especially the “Save plugin data”), then give the file a different name so that you’re not stepping on your original work…(i.e. add “_stripped” to the end of the file name), and then click the “Save” button… Now close Rhino. Start Rhino and load the “stripped” version of the file… Can you get things to go black? If so, which operations cause the blackness to occur?

That’s all for now…in the mean time, I’m going to be trying to put together a system here with similar specs.

Thanks,
-Jeff

Hi Jeff

As you’ve suggested I have exported clean geometry only, resulting everything being on default layer.

The scene loads, all object seen in wireframe mode, then:

shaded - OK

rendered - OK, starts witch black screen then after 1-2 seconds displays correctly

ghosted - OK

artistic - OK

technical - OK

pen - OK

arctic - BLACK, zooming in, changing camera angle doesn’t help

raytraced - OK but with an extreme long loading time (orange bottom bar)

I have attached all my options exported in .ini file which inludes all display mode settings. Maybe this can help.

Regards

P

RH 6.14.ini (317 KB)

To make it even more confused.
I am saving images with castarted scenes and then merging pics in photoshop.
Sometimes, when setting the camera and target display mode, there are some glitches like fake transparency or objects on top of each other, but when I change the display mode for a while and then set it back to desired one, there is a great chance that display will return to normal.

Did you share the model that does this already with @jeff? If not can you please upload it at rhino3d.com/upload?to=nathan@mcneel.com (use this link and I get automatically notified when the upload is done). I’d like to investigate why load time is extremely long.

Yeah, I did it yesterday.

Ok, I’ll get it from him, thanks!

Hi Nathan
I am not sure, whether it is within scope of your responsibility but it would be worth looking into another problem:
once you have my file, please play with turning on and off the INTERIOR/SHELVES/BOOKS layer and observe dramatic drop of performane (at least here). I know it is a lot of objects (<50k) but there are mesh faces only.
P

Hi @Piotr,

I managed to investigate it earlier this morning. Indeed the 48k+ objects is the problem here. To have this scene start rendering fast also with Raytraced select all objects on your INTERIOR/SHELVES/BOOKS layer and use _Join to merge the 48k+ meshes into one. Once done that switching to Raytraced will be under 10 seconds or so.

As an aside, it is pretty useless to turn on the interior objects when they aren’t visible from the angle(s) you are rendering. Turn them off when they aren’t visible and save resources, make the rendering faster.