Display properties panel doesn't work

Hi all,
I opened the Display Properties panel in Rhino 8WIP and it doesn’t work at all, it is permament frozen.
Plus, I don’t have the option to scroll down the window when the panel is contracted.
I relaunched Rhino wip several times and nothing happened.

Hi Jordi -
Please run the Rhino SystemInfo command and copy-paste the result here.

Hi Wim,
Here you have.
Rhino System Information.txt (2.7 KB)

Hi Jordi, can you try updating your display drivers for your quadro? They are quite old, and most likely updating these can resolve your issue.

I updated the driver and still not working display properties panel:

Rhino 8 SR0 2022-11-15 (Rhino WIP, 8.0.22319.12305, Git hash:master @ a78287b93af89333d2c1832fd6a67d321a15ee29)
License type: Commercial, build 2022-11-15
License details: Cloud Zoo
Expires on: 2022-12-30

Windows 10 (10.0.19044 SR0.0) or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [100% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) HD Graphics 530 (Intel) Memory: 1GB, Driver date: 1-8-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA Quadro M1200 (NVidia) Memory: 4GB, Driver date: 11-2-2022 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 526.67
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 11-2-2022
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 8 WIP\Plug-ins\Commands.rhp “Commands” 8.0.22319.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 8.0.22319.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 8.0.22319.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 8 WIP\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 8 WIP\Plug-ins\Constraints.rhp “Constraints”
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCycles.rhp “RhinoCycles” 8.0.22319.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoRoslyn.rhp “RhinoRoslyn” 8.0.22319.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCodePlugin.rhp “RhinoCodePlugin” 8.0.22319.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\RhinoCode\RhinoCPython.rhp “RhinoCPython” 8.0.22319.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 8.0.22319.12305
C:\Program Files\Rhino 8 WIP\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 8 WIP\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 8 WIP\Plug-ins\ConstraintsUI.rhp “Constraints UI” 8.0.22319.12305

can you try starting in safe mode and see if the problem persists? For now the only suggestion I have otherwise is to try reinstalling v8

The Intel driver is almost 2 years old. You might try updating that as well.

Hi Gijs,
Neither save mode start nor reinstalling v8 worked, I am going to try to update intel driver as AIW said and see.

I think you’ve somehow turned on a panel that is still under construction through a test command.

Please try running the DisplayProperties command and see if you get a different but similar panel.

1 Like

Yes, It works perfectly, when is executed from the command prompt.
When is it activated from the toolbar space, it doesn’t work.

1 Like

Ahh yes, that makes sense. I’ll make sure to write Test in front of the one that says “Display Properties” for the next wip! Until then click the one that says Display and not the one that says “Display Properties” Thanks @jordi.rovira