Dimension problem in rhino 6

I appear to be having some dimension problems in Rhino 6.
When repeating a dimension command I keep getting a continuous dimension instead.
Once it happens, that’s it stuck.
The only way to clear it is to restart the program.
It doesn’t look like I’m doing anything wrong but any ideas?

Hello - what happens if you click on the Continue command line option - does it toggle?


If I click on the continue command line option it does the same as the line command. Right click brings up the same command as left click also.

Does that mean that the command line reads Continue=No when you toggle?
Can you run the Rhino SystemInfo command and paste the result here?
Also, does this issue also happen when you start Rhino in safe mode?

This is an intermittent problem. It doesn’t do it all the time. It seems to get stuck on a continuous command which I can’t get it out of unless I restart.
If I, for example, dimension a curve with the linear dimension command, all is well until I try to dimension the next curve where it asks for the second dimension point immediately. I can’t get back to a non continuous dimension. It also happens in aligned.
I thought something was sticking on the keyboard or mouse but it appears completely random.
If it does it again I will save the line command and post.
Thanks for the help.

Can you run the Rhino SystemInfo command and paste the result here?
The next time this occurs, please try to remember which steps you were taking right before that happening.

Rhino 6 SR10 2018-11-7 (Rhino 6, 6.10.18311.20531, Git hash:master @ 0f9089a0035dcc6955732d57071445ecc29390f0)
Licence type: Commercial, build 2018-11-07
License details: Cloud Zoo. In use by: grahamriddellsfx ()

Windows 10.0 SR0.0 or greater (Physical RAM: 16Gb)
Machine name: DELL

GeForce GT 650M/PCIe/SSE2 (OpenGL ver:4.5.0 NVIDIA 369.09)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.5
Shading Language: 4.50 NVIDIA
Driver Date: 8-1-2016
Driver Version:
Maximum Texture size: 16384 x 16384
Z-Buffer depth: 24 bits
Maximum Viewport size: 16384 x 16384
Total Video Memory: 2 GB

C:\Program Files\Rhino 6\Plug-ins\SolidTools.rhp “SolidTools”
C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 6.10.18311.20531
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”

Hi Graham - just to be sure - when a dimension starts in this state it usually means that either the last time the command was used it was in Continuous=Yes mode or that it was started using a macro that sets Continuous=Yes, which does exist on the right-click of the button that starts the Dim or DimAligned commands -


Either way, the command line option that says Continuous=Yes should toggle to Continous=No if you click on that option, and all should return to normal - does any of that make sense with what you see?


Yes, that is exactly as it is at the moment and all works fine.
Yesterday it seemed to go a bit crazy on me!
It hasn’t done it today…so far.