Dimension frustration


#1

I set my dimensions in V5 with the model scale factor. Default is 1, Default .5 is model scale .5, Default 1.5 is model scale 1.5 and so on. Annotative scaling is off. What I see in my layout is what I see in my viewport. All the features of the dimensions scale up or down automatically depending on what I set model scale to. Simple and easy.

I can’t figure out how to do that in V6. If I check Enable scaling, the dimensions are each a different size in the viewport (which they should be) but the same weirdly small size in my layout.

If I uncheck Enable scaling all the dimensions are the same size in my viewport and the same size in my layout.

I don’t want any scaling to occur. If I set one dimension to be twice the size as another dimension (Default 1 and Default .5 for instance) I want to see that in the viewport and the layout.

Thanks for any help you can offer.


Ghtext as geometry : i.e. chance to use the generate text and transform it
#2

This is from V5 and what I’m trying to achieve. Seems simple and obvious enough but I can’t seem to do it.

Viewport:

Layout:


(John Brock) #3

In Options > Annotation Styles, on the right side under the buttons, mess around with the “Enable Scaling” check box.

From the Help file:

Enable scaling
When the Enable scaling option IS checked, text, dimension text, and leader text in a layout detail get their scale factor from the Detail display scale.

When the Enable scaling option is NOT checked, text, dimension text, and leader text in a layout detail AND in model space, get their scale factor from the named dimension style they belong to.


#4

Thanks for your reply

I realized, looking through this post today that my point can be made much simpler.
This is how I set up dimensions in V5. Scaling is Off. I control the size of dimensions with Model Scale which is convenient as all components of the dimension scale automatically.

This is what I get in V5 - the dimensions in the viewport are the same as the dimensions seen in a layout:

No matter what I do in V6 I can’t get the same results and I find it counter intuitive. If I want to see the same thing in the viewport in 6 that I see in 5, I have to turn scaling On. But if I do that, then the dimensions are all the same size in the layout. But if I turn scaling Off they’re the same size in both the viewport and the layout.

V6DimensionProblems.3dm (40.8 KB)


(Mary Ann Fugier) #6

Hi Alex,
Can I get your model? (Sorry if you already posted it.)
I see the JPG, but I would like the 3DM.
I know you describe what setting to use, but I prefer to get an model with the issue.

Thanks for your help.
Sincerely,
Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA


#7

Mary Ann -

See the post above. I simplified the post and attached a file to explain what my issue is.


(Mary Ann Fugier) #8

Hi Alex,
This is definitely broken, again.
You are exactly right.

When Annotation scale is un-check, the text size should not be scaled in the Layout.
You should see exactly the model space text height that you have created, no scaling to adjust the text height on the layout. This is precisely why “Annotation Scale” is turned off.

I know this is important because Rhino 5 models should open in Rhino 6 and look as at least as good as they do in Rhino 5. We need to make sure this is not broken when Rhino 6 ships.

I will get this on the list again. I will post the Tracker number soon.
Thanks for bring it to our attention.

Sincerely,
Mary Ann Fugier
McNeel Technical Support and Training
Seattle, WA


(Wim Dekeyser) #9

I’m not saying that it works “as it should” but it does seem to be working “as advertised”.

As it is, the font size of a dimension in Rhino 6 is defined by the layout size. Un-checking annotation scale should then use that value in the model space. And it does.

You write:[quote=“mary, post:8, topic:42294”]
When Annotation scale is un-check, the text size should not be scaled in the Layout.You should see exactly the model space text height that you have created, no scaling to adjust the text height on the layout.
[/quote]

That would be exactly the opposite of the way it is implemented.
I guess it is implemented the way it is to make it easy to make dimensions on details - and that’s a good thought.


#10

I hope Mary wins out over Wim in this disagreement.

To me it’s screwy and prevents me from moving from V5 to V6. It’s disappointing to see such a central feature be radically changed between the two versions.

Furthermore, I don’t understand this. Scaling doesn’t affect dimensions in the Viewport in V5 but it does in V6 except it’s backwards from what I’d expect. See the attached.

Whether this is an improvement or not isn’t for me to say. But it does mean that I can’t work back and forth between V5 and V6. And, to use V6, I would have to abandon my basic workflow which is to create a Make2D of my model and then dimension it in the Viewport in Top view with scaling off, knowing that what I will see in my layout is exactly what I just created in the viewport.

That seems to be no longer possible.


(Wim Dekeyser) #11

I’m not sure I was disagreeing. I’m just trying to understand how this works. I have tried in the past as well and it seems like I’ll never get it.

I see changes between Rhino 5 and Rhino 6 when in use. When I read what it says under Document Properties > Annotation Scaling, though, I would expect it to work the same way in the two versions. But it doesn’t.

I’m totally with you on that one.

And there we have it. Why doesn’t it?

When I set my dimension in RH5 to be 5 mm and have scaling on and at 10, I expect a dimension in the model space to be 50 mm high but it is just 5 mm.


(Wim Dekeyser) #12

And, of course, if you have two dimensions styles that look the same in model space and you have scaling turned off, they should also look the same in a layout.


#13

I would reply to this by referring to AutoCAD conventions - scaling is something that only happens in the layout, not in model space. Annotation scaling allows you to see a dimension in a 1/4" scale layout the same size as it is in a 1" scale layout. So, to that extent, V5 works as expected to me.

To explain a bit further - let’s say you have two layouts in AutoCAD, one set to 1/2" scale the other set to 1" scale. In that case there are actually 3 dimensions in the drawing - the dimension you’ve set for model space, the dimension sized for a 1/2" scale layout and the dimension sized for a 1" scale layout. What AutoCAD is doing is hiding two dimensions depending on where you are - the model space dimension and the dimension sized for a 1" scale layout are hidden when you’re in the 1/2" scale layout so you only see the correct size dimension. In model space the two dimensions sized for the 1/2" and 1" layout are hidden.

I hope that’s not too confusing.

But, as in V5, you can turn off annotative scaling in AutoCAD and it’s off globally - no scaling anywhere - what you see is what you get.


(Mary Ann Fugier) #14

Hi Alex,
You are 100% correct here, IMO.
I appreciate all the background and details.
I posted bug RH-38630 for this issue.

I also have drawings that I did in Rhino 5, whose annotations are no longer displaying correctly. I believe this is only a bug. Like I said earlier, our first goal always needs to be, “do no harm”. In other words, do not change our customers (and my own selfishly, yes) models/drawing that we did in Rhino 5. Then add some cool features.

Do you agree with this summary?

  • Dimension and other annotations should not be adjusted for scale in Model space or on a Layout if the “Use Annotation Scale” in Options is not checked.
  • Dimension and other annotations should not be adjusted for scale in Model space if the “Use Annotation Scale” in Options is checked.
  • Dimension and other annotations should only be adjusted for scale in Layout space if the “Use Annotation Scale” in Options is checked.

If anyone is still needing help with Layouts and Annotation scale, I have this presentation that I did ironically March 26 2014.

Sincerely,
Mary Ann Fugier


#15

Mary Ann

Thanks for all of your attention to this.
Yes, I agree with your list and look forward to a time when I can dimension
in V6 exactly as I do in V5.

I watched that presentation numerous times when I was transitioning from
AutoCAD to Rhino. I still consider it essential viewing for anyone
intending to do layouts in Rhino.

Thanks again.

Alex


V5 to V6 annotation compatibility
(Lowell Walmsley) #16

@mary @arail -

There are intentional differences in how dimension scaling works in V6 from in V5.

The way dimension scaling works in V6 is the way it is designed to work. It doesn’t appear to me to have any scaling bugs, in the sense that it works the way it was intended. That may be different than you want it to work, which is a different and probably more important discussion, so I’ll explain some of the reasoning.

The reason for making the changes is that people had trouble getting predictable results in printing from layouts especially.
In order to get consistent 3mm high text in layouts when two details are scaled differently, you needed two styles with different scale factors and you needed to calculate the inverse of scales and sizes.

In V6, if you want text in layouts and prints from layouts to be 3mm, you set the text height value in the style to 3mm. Dimension scaling doesn’t affect the height in layout space. It affects the height of text in detail model space in layouts, so changing the annotation scaling check makes no difference in layout space.
If you want the text a different size in model space viewports, you can leave annotation scaling checked and change the ModelSpace scale value, which will make the text bigger or littler in model space. Changing that won’t change the height in layouts.

The reason for making he height in layout space consistent is that layouts are are more likely to have specific viewing scales related to printing at certain sizes while model space viewports are more likely to be zoomed in and out to arbitrary scales so setting text to a specific size is less likely to make it always readable.

That’s not the way it works in either V5 or V6.

In V5, whether or not “Enable scaling of dimensions, text and leaders” is checked, dimensions in ModelSpace are always scaled according to the ModelSpace scale value.

In V6, “Enable scaling” controls whether annotations are scaled in ModelSpace and also whether annotations are scaled in LayoutSpace.

That is the way V5 works and the way V6 works.

The difference between V5 and V6 is that “Enable scaling” controls both ModelSpace and LayoutSpace in V6 and only controls LayoutSpace in V5.

Alex, to make reading your v5 files easier, we could look at doing a few things.
I don’t have your V5 file for your example to be sure exactly what you started with, so maybe you could post that, but I think the values are correct in the V6 file, (I could verify that with your V5 file) and that only the scaling behavior is different.
It seems like if we added a separate control for Enable layout scaling, you could turn on ModelSpace scaling and turn off Layout scaling and get the same behavior you use in V5.

I don’t really like adding another control because it makes another place things can get confused, but maybe we could label it something like V5 compatibility mode.

We’ll keep working on this until we get something that works.

Lowell


(Lowell Walmsley) #17

I was wrong about just disabling scaling in LayoutSpace. I think we would have to apply ModelSpace scale in model space annotations in Details in compatibility mode.


(Wim Dekeyser) #18

Still only trying (hard) to understand dimensioning.

What does that mean, exactly?


All that follows is RH5!

I have a dimension style defined with Document Properties > Annotations > Dimensions > [My_Style] > Layout sizes > Text height set to 20.0.

That would seem to indicate that my dimensions as see on a layout (i.e. no matter if they are drawn ‘on’ the layout (either snapping to geometry seen in a detail or geometry residing on the layout) or seen in a detail (i.e. they were drawn in ModelSpace but visible because the detail opens a window over it)) will be 20.0 [units].

Document Properties > Annotations > Annotation Scale > Enable scaling of (…)
Here it says “Model space text scale”. To me, no matter if this is checked or unchecked, it will never do anything with what I see in a layout (that being dims ‘on’ the layout or ‘in’ a detail).

If Unchecked, I would expect dimensions in ModelSpace to be the same as in a layout - in this example 20.0 [units]. If Checked, and e.g. set to 10.0, I would expect dims in in the ModelSpace to be 200.0 [units]. But this is not the case.

You write that it should be 200 regardless of the ‘enable’-state. Why? And why isn’t it happening?


After more testing I now see that scaling only affects dimensions that are seen ‘in a detail’. Is that what is called ModelSpace? If so, what do you call the 3D environment in Top-Right-Front-Perspective-Etc viewports?
And absolutely nothing at all changes if I change the scaling from e.g. 10 to 50 to 100.

Picture 1 - No scaling


Dimensions in red are “in 3D” - the picture shows that they are not scaled to be 20 units in the detail in the layout.

Picture 2 - Scaling enabled - scale 10


The red dimensions are now scaled to be 20 units in the detail in the layout. But not 200.

Picture 3 - Scaling enabled - scale 100


I don’t see any changes. Not in the layout, not in the detail, and not in 3D.


#19

Respectfully, I disagree with your terminology here. Setting a dimension size with the Model Space Scale is most definitely not scaling. The term scaling in every application I’ve used means annotations change in size relative to geometry depending on the scale the layout is set to. Setting a dimension size with the Model Space Scale is no different than creating different sized geometry - it doesn’t change in size when I zoom in or out in a layout if scaling is disabled (in V5).

Mary Ann Fugier’s list refers exactly to how scaling works in V5 and in AutoCAD and I would wish it were adopted as such in V6 without all this complication. Scaling means your annotations change in size relative to geometry depending on what scale your layout is set to, disabling scaling means your annotations do not change in size relative to geometry when seen in layout. Simple, obvious and effective - and it allows those of us who want to toss annotation scaling overboard to do so.


(Lowell Walmsley) #20

It means that in V5, the Enable scaling setting doesn’t control scaling in mode space. The sizes in dimensions in model space are always scaled by the model space text height regardless of the setting being checked or not.
I think that’s a big part of what the rest of your post says too.
Part of the changes and reorganization in v6 is meant to make that all more clear and understandable.


(Lowell Walmsley) #21

I’m working on making it possible for you to selectively turn scaling in either or both of model space and layout space on or off.