DENDRO | how to fix : Unable to load DLL 'DendroAPI.dll'

Helo community,

Sharing my solution of DENDRO plugin throwing you « Unable to load DLL ‘DendroAPI.dll’ » error.

It can be solved by turing COFF off. Thing you can do in rhino by typing the command : DrasshopperDevelperSettings and then unchek Mermory Load option.

Now, I don’t recommande using this method as other Grasshopper plugin will require COFF on (like elefront, pufferfish, etc).

Instead, open grasshopper, go to file > solver > seek for DENDROGH and change the Load Mechanism to the orange disc.

Don’t forget to restart Rhino.

Should Work.



Hello @billytalent.exe,

I followed exactly the solution detailed above, but it did not work. Instead, now when I open the “dendro lattice” example file, I get an “Unrecognized Objects” box (see image). I then hit Download and Install, and it gives me a “Package Restore” popup. Dendro does not even show up as a tab in the upper part of the screen. I appears to be completely gone.
I have gone through Special folders > Components folder. When I did that Dendro was still there. I tried deleting it and re adding it to the folder. But no matter what, it wont show up in any part of the GH user interface.

Thank you for your help.


That prompt has nothing to do with dendro, that is the yak package manager and will try to install plugins that gh needs for a file, the problem is that the developer of the plugin needs to make their plugin work with yak (most have not, including myself).

Your issue seems like you might have not unblocked the dendro file. Right click it and go to properties. If there is a check box next to the words unblock, select it and hit apply, ok. This rule goes for all gh plugins depending on your windows firewall and server settings.

@Michael_Pryor thanks for responding.

I just followed what you said and unfortunately it didn’t change anything. My problem is that basically ever since I did the fix above (changing Load Mechanism), GH doesn’t seem to acknowledge that Dendro even exists. Even when I delete and reinstall it (unlocked). To be clear, Dendro used to show up inside GH, but it doesn’t now.

It no longer shows up in the “Plug-in Loading” section that Charles referenced (see image). Dendro used to show up in the area circled in red before I changed the Load Mechanism.

Thanks for your help!


Have you tried this also? (Grasshopper Developer Settings–>disable COFF)

Yes, I’ve tried that. Thanks.

  1. Solution exception:An attempt was made to load a program with an incorrect format. (Exception from HRESULT: 0x8007000B)

I am getting this error after I did the procedure suggested by CC, How can i fix this problem?
Help please . Thank you

i downloaded and installed Dendro today with no issues (just the examples provided). I just unblocked and it was good to go.

Hey everyone. I am getting the same error, and in my script it seems like only one of the Dendro components is not working (the Mesh to Volume), while the others yes.

I tried the solution from GH Solver, but that didn’t solve it.

The error I get is this: 1. Solution exception:Unable to load DLL ‘DendroAPI.dll’: The specified module could not be found. (Exception from HRESULT: 0x8007007E)

Haha, solved it! I had forgotten to copy the .dll files into the GH Components folder :smiley:


I’m happy to be able to solve “Unable to load DLL”. thank you

1 Like

Thank you, Emma, that worked like a charm.

Solution Worked for me