Deleting layers, problem with block


#1

I often have confusion with layers and blocks,
I just got the problem once again so I decided to ask for help:

chronologically:

  • I have a layer with blocks
  • I select the objects in that layer called layer0 and change layer to the new destination layer called “box”
  • then, I check: it worked because the origin layer0 is empty (I use select object: “no object in this layer”)
  • I try then to delete this layer but I get: “there is a block definition named Component3 in layer0…check block ´manager”
  • so I check blockmanager and delete this component 3.
  • After that, I try again to delete the layer0 but now he says that there is a component1 in layer0, so I go to delete component1
    and it goes, etc, etc… :wink:

I tried with explode, it doesnt help

any idea? or understanding of all this block and layer process?

thanks :smile:


(Pascal Golay) #2

Hi flo- you can use BlockEdit to change the layers of the objects that are in the Block definition so that no part of the underlying definition resides on the layer you want to delete.

-Pascal


#3

I typed “blockedit” but it says “unknown command”


(John Brock) #4

This should help:
http://wiki.mcneel.com/rhino/usingblocks?s[]=blocks
Pay particularly close attention to the third paragraph under “How blocks work:”


(Margaret Becker) #5

What version of Rhino are you using? Rhino V4 or Rhino 5? The BlockEdit command is in Rhino 5.


#6

Rhino 4


(Pascal Golay) #7

In V4 it will be more complicated for sure, but what you can try is the attached plug-in for V4- the command is InPlaceAssemblyEdit and it behaves similarly to V5’s BlockEdit. It is a prototype and not as reliable but it may get you what you need- that is, edit the block and while editing, assign all of the objects to some layer(s) that is not the one you are trying to delete.

InPlaceAssemblyEdit.rhp(112 KB)

More info here
http://wiki.mcneel.com/labs/blockeditor

but the plug-in I posted has a different command name: InPlaceAssemblyEdit

-Pascal


#8

yes, worked quiet well, I can edit one block at a time


#9

In case anyone in the future (i.e.2017 v5) looks at this thread, the link to the wiki page is very helpful.

In it, there is the suggestion to use “Purge” command to get rid of unused Blocks. This worked for me - ***NOTE: Check out the options in the command line so you don’t mistakenly get rid of other things you’d rather keep, like layers, et al.