Decals not showing

I applied many decals to polysurfaces for a work project and now they are not showing in the shaded or rendered display modes. When rendering, they show up. I really need them to show up in preview mode to work efficiently.

help us help you…

1 Like

It could be a material or display mode setting or related to your graphics card and it’s driver. As a quick fix, I might use Raytraced mode set to only 10 samples via the sample count in the lower right of the viewport when in that mode. That should show the decals and let you adjust prior to running the Render command.

nobody can help if you dont start posting files… i can see you had an issue several month ago where you seemed to have ignored all requests for further materials.

other then that i can only imagine that you have used SetObjectDisplayMode set to shaded for instance, then decals would not show up anymore. try activating that command on the object in question and just execute it without setting anything.

If you have a transparent material on which you try to apply decals they’ll essentially look like they disappear.

oh and for them to appear in shaded mode at all you would have had to meddle with SetObjectDisplayMode already, setting it to rendered for that object.

Hello all, I apologize for the delay.

There seems to be no rhyme or reason to when or why this appears. I exported the items to another file and they appear fine in shaded and rendered (I have my faces set to dispaly with their rendered material in shaded mode). Whether or not the decals show up in either file is totally unpredictable at this point. I tried relinking the decals and nothing resets, and they render ok.

System info:

Rhino 7 SR25 2022-11-22 (Rhino 7, 7.25.22326.19001, Git hash:master @ 2a680490f96a04550d1f39158b859c4f7739d024)
License type: Evaluation, build 2022-11-22
License details: Cloud Zoo
Expires on: 2023-02-25

Windows 11 (10.0.22000 SR0.0) or greater (Physical RAM: 16Gb)

Computer platform: LAPTOP - Plugged in [90% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 620 (Intel) Memory: 1GB, Driver date: 3-8-2019 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Windows Main Display is laptop’s integrated screen or built-in port
Primary OpenGL: NVIDIA GeForce MX150 (NVidia) Memory: 4GB, Driver date: 9-13-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.12
> Integrated accelerated graphics device (shares primary device ports)
- Video pass-through to primary display device

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 9-13-2021
Driver Version:
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 4 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Chaos Group\V-Ray\V-Ray for Rhinoceros\V7\VRayForRhino.rhp “V-Ray for Rhino”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.25.22326.19001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi @jajajackjack ,

Update the graphics card drivers for each GPU in your machine. Use the Notifications panel from the Panels drop down menu in Rhino 7 for Windows to get links to the respective manufacturer’s driver download sites. Download and install the driver updates with Rhino closed and restart Windows before testing if that helped.