Dark Tint Glass failing in Rhino 8

Dark glass worked fine in Rhino 6 and 7 using Legacy Render engine and using black for the tint… (never tried in Cycles.) Love the faster rendering speed using Cycles in Rhino 8 but blacks and dark greys wont let the light through and Legacy render is a total failure. Image of the boat below is Rhino 7 Legacy. The stripy image is the result I get using legacy render in Rhino 8.

Colors in glass materials are essentially filters. Black means nothing goes through. Increase the value to something lighter until you get a glass effect you want.


in general you’ll want lighter colors for colored glass. The darker the color the less light gets through.

Something is wrong here, I just made a simple scene and made a black glass material with 100% transparency and then changed it to dark red and red and the icon didn’t update and Rhino froze. PC, RTX 2070.

I’ll test a little bit more.

Here is a file to test, doesn’t get simpler than this.
Just turn on raytraced and mess with the layer material. I did a few adjustments to the material now and Rhino crashed. R8.6

Black Glass freeze.3dm (179.9 KB)

Update to at least 8.7, material fixes have been made.

And if you don’t have a GPU driver of this year then update to the latest studio driver and do a clean install for the driver.

1 Like

Took longer to crash in 8.7, but opening the material from the Materials list and dragging around the color wheel crashed it in two minutes. (Rhino freezes)

I have the 551.62 studio drivers (february 2024), I’ll update the drivers just in case)

Ah, you’re using the floating editor - I never use that. I’ll see if I can repro that tomorrow on Windows. Couldn’t get it to crash on my M2 though. Neither through the materials panel, neither through the floating editor for the material when opened through materials panel. I gave up after five minutes of changing color by dragging around the color wheel.

Also, what render device are you using? CUDA or Optix?

edit: I did try for 8 minutes more and recorded the screen - let me know if I did anything different than you: https://www.youtube.com/watch?v=mt3R_WBRw3E .

I’m on Rhino 8 version Version 8 (8.7.24138.15432, 12024-05-17)

As mentioned, use a lighter color instead of full black. Below you can see how much filtering happens when you go darker and darker, until all light is blocked with black

The top image is the preview in the Rhino 8 Render Viewport. Material color Black Transparency 50%
The second image is the rendered image using Rhino 8 Render Material color Black Transparency 50%
The third image is the “completed” render in Legacy. Occasionally Legacy will produce a good rendering but is very very slow. Usually it locks up (does not crash - just freezes).

Bottom line is that in Rhino 6 and 7 over some years I have created hundreds of successful renders with transparency with a black or very dark material (sometimes adding dash of blue- but still very dark).

Something has changed.

Are you using the Rhino Custom material? If so don’t do that. Either use Glass, or use Physically Based material.

You can start out with Glass, then change it later to Physically Based, after which you can also play a bit with alpha settings. Glass is basically Physically Based with opacity amount set to 0.0.

On the left three glass planes with the color set to mid grey, on the right three panels with a duplicate of the first material, but with alpha set to 0.87. Note though that depending on the angle you’ll see more of the environment reflected in the glass.

Same panels, now from above, and the alpha on the adjusted material dropped to 0.70

Over the last three days I have tried numerous materials and transparency settings.
The last three images were custom - I just ran another render using glass. Result enclosed.

I’m also enclosing the Rhino 8 file I’m using.

Transparency Test 200524.3dm (70.0 KB)

The black area of the top two planes is because you have coincident geometry.

Moving one of the planes ever so slightly, say 0.001 units, ensures you don’t have coincident geometry

Having the groundplane on with this also cause similar issue with lowest panel.

Here I changed the full black to mid grey, and added an object to view through the panels

Note that you’ll see unexpected refraction. This is because you have only a single entry point, not an exit point. For that select your panels and add thickness, even 0.01 should be enough

And rendered from above , note still lots of environmental reflection in the panels.

Attached the adjustments I made

tgra__Transparency Test 200524.3dm (101.4 KB)

This isn’t personal Nathan, but this comment doesn’t cut it from a user point of view.
IF we are not to use it You are to not include it in a new release. And changing how Rhino 8 handles dark glass from how it has “always” been isn’t backward compatible with old files so that isn’t cool either, at least not when opengl and rendered still doesn’t handle transparency in the same manner. OpenGL looks much better now though!

Point is: make it easy for the user, adapt wysiwyg as far as possible and remove stuff you don’t want us to use. If converting to physically based is the way to go then just do that under the hood and we will be happy campers. But the glass material is too simple, so is plastic and others, so we often need to switch to custom (or pbr) to be able to add textures etc. So make that good for both you and us :slight_smile:

Hope you see this as constructive criticism, you are all doing great work, it just needs to be pulled together a bit.

PS! Installed latest studio drivers and tested on 8.7, adjusted the glass material a bit (to dark red) and turned on raytraced and it crashed immediately. No crashreport. I will test one more time.

Edit 2:
Made a new file, added a box, put on layer, added glass material, turned it red, turned on raytraced, all worked fine. Opened material editor, double clicked material and clicked on Color and Rhino froze. No crash, but had to kill Rhino. CPU is running constantly on 11-12 % on Rhino, 8 core 16 thread cpu (10700) so that means one core 100%, doesn’t it?

What else can I try or do to help you out on this?

1 Like

I know, I have been campaigning for a long time to get it hidden/removed. I will continue to do so.

1 Like

Lets move the crashing into a different topic and keep this on dark tinted glass.

1 Like

I must have tried almost every material that you can make transparent- on a whole range of grey shades and transparency settings. On this render Rhino 8 cycles my color is almost white and I’m still getting black opaque windows on the render.

Upper image is the Render View Port

Screenshot 2024-05-22 at 18.30.36

One of the these is glass, The other is physically based. Result is the same

Screenshot 2024-05-22 at 18.51.17

As far as I’m aware all of my system software including the GPU is up to date.

That looks like coincident geometry to me, just like I showed in my post two days ago: Dark Tint Glass failing in Rhino 8 - #13 by nathanletwory

Make sure you don’t have double geometry there. Look for duplicate glass panels and delete what you don’t need.

If you think that is not the case please share the file with me for investigation. You can do so confidentially using Rhino - Upload to Support - my address is prefilled. I’ll be notified when the upload is ready. Make sure you zip up all necessary files into one package for ease of investigation.