Cylces performance degraded in this wip


#1

Hi,
Cycles is back to going into dust mode when I rotate or pan a cycles viewport. Before cycles would go into rendered view when one rotated or panned but now that is not working cleanly like it was in the past wips. This is a step backwards in performance again. Also cycles is using up huge resources and is causing my fan to kick on at high speed where before it didn’t do this.
RM


(Nathan 'jesterKing' Letwory) #2

That is the progressive refine you see, not a degradation in performance. If anything it is faster. Due to a bug those frames were skipped while drawing, so actually there was always a gap between start of rotate and the first draw of Cycles.

Now, I agree that the effect is jarring. This is something I am and will be working on for the time being, that is performance. You can expect things to change still in the coming weeks.

The change to Rendered mode can be gotten back, as it is behind an advanced option. You should be able to toggle UseFastDraw to get that back. (Fingers crossed I didn’t break anything there).

Regarding resource usage I don’t think I changed anything specific to that apart from eliminating buggy logic that was causing draw loops to idle needlessly. I guess this causes better GPU usage. Perhaps check your throttle is still on its default 10ms.

Anyway, thanks for testing and reporting (:

/Nathan


#3

Hi Nathan, for my case actually the viewport realtime rendering seem to hog the resources and while it renders I have trouble getting the context menus up or selecting objects.
This 4K screen on laptop is also not helping… high resolution previews just eating up resources…


#4

@nathanletwory
Is there macro for pausing resuming the viewport render? Thinking maybe to assign to a button.
Also if there’s macro for setting things in the advanced menu that’d be great.


(Nathan 'jesterKing' Letwory) #5

I don’t think there is command for that yet. Pausing is done in the HUD at the bottom of the viewport.


#6

Are those planned to be implemented? It’d be nice to have it.


(Nathan 'jesterKing' Letwory) #7

Logged request as RH-42000


(Nathan 'jesterKing' Letwory) #8

btw, you can disable that by setting advanced setting RhinoCycles.StartResolution the value 2147483647. With the next wip it should be enough to set UseStartResolution, but I accidently broke that recently, so setting the first one to maximum int directly works.


(Brian Gillespie) #9

RH-42000 is fixed in the latest Service Release Candidate