Cutting solids by extrusion

I am trying to cut through a solid I have created by ‘sweep through 1 rail’ of a profile. You will note an outline I have created below the extrusion. My intention was to extrude this straight up and then subtract one part from the next. This will render a star like solid. Is this methodology sound. Any suggestions greatly appreciated.

Hi Mathew- Basically. yes - but I’d make the object as a revolved profile, if it is meant to be perfectly round, and I’d make sure the points (inner) of the cutter curve do not lie exactly on an edge as seen from Top, of the solid you are cutting - bring those a little in or a little out, if the design can stand it. I’d also bring (extend) the ends of those curves well outside the outer circle of the target object and join the ends with short arcs so that you have a continuous single ‘saw blade’ curve to extrude.


A nice all-in-one command for that kind of operation is the WireCut command. Connect up all the scallops as Pascal suggests, join them as one curve, then run the command. In Perspective view, you can draw the “hot wire” straight up through your solid until it is well above, enter, enter again (ignoring the second cutting direction) and decide which parts you want to remove. It will leave you with the parts removed and the cutting faces closed to form a solid again.


Pascal and Maxz

Thank you for your input. I have worked on this for nearly a week now, recreating the parts and learning about Rhino. Still it does not work. When I did the wirecut the first time out I ended up with two solids. It was not possible to subtract or delete one solid from the other. I then tried the Wirecut using a single wire. I did all the things suggested - extending the curve outside the principle solid, I revolved the profile of the solid to be cut, ect. Still no joy. I thought maybe my cutting profile was not joining but I think this is not the problem. Ant suggestions how I might trouble shoot this.

Thanks in advance.


Could you post the file?

Duplicated line sections in the cutting wire maybe? Explode your cutting curve and run SelDup once or twice, any duplicated lines will be highlighted.


Here is the posted file.ForumPost 01.3dm (584.5 KB)


I ran SelDup and in fact there was a duplicate solid. But the wire still would not cut. Here is the 3dm without the duplicateForumPost 01.3dm (248.9 KB)

Hi Matthew,
you did have a duplicated line in the profile that you revolved to create your polysurface, hence it became an open curve creating an open polysurface. It needs to be closed to be able to use wirecut on it, check the properties panel to see whether it is open or closed (same for the profile curve).
I deleted the polysurface, exploded the profile, removed the duplicate line, rejoined the profile and revolved it to create the ring again. After that, WireCut worked as expected, but I had to deselect the “Keep All” option to be given a choice of solids to delete. I also had to use the “invert” option to get the required result.

what @maxz said… I alternately used DupEdge and then picked the edges making the revolve profile. Join those together, Revolve and Wirecut.
ForumPost 01_brianj.3dm (1015.6 KB)

Max Z
Thank you for your time considering my problem.

Much obliged