Curve Length Dimensions were initially numbers but now ####


#1

Hi,

V5

My Curve Length Dimensions appeared as numbers, then a while later they are just #### with arrow. I create a new one and its a number.
The only thing I have done in that time is go to properties to change tolerance to 0.1 units from 0.01units as lines wouldnt join. and the next dimension I created was a small font, checking it I saw it was somehow default so I must have touched a setting during my visit to properties and into units though dont recall doing so. I set it to dimension 02 and all was well. then later I noticed the dims I had painstakingly created had gone ####.

What do I do now ?

This could be a big issue as I am about to create loads od these, as it is thats an hours work wasted unless I can get my numbers back.

File attached of just a few.

Steve

Dims on Crv become hash v5.3dm (39.7 KB)


(Pascal Golay) #2

You must have done something else to the curves because the object IDs of the current curves are not the same as the ones in the text field.

-Pascal


#3

Hi Pascal,

I did the dimensions of a lower set of curves, then when I came to do the upper set, they were in bits from being projected onto separate skins so I had to join them, the bottom curves though were fine and remained untouched, yet even their dims went ####.

I have had to redo the lot. Something simple upset them all, and believe you me the lower curves were fine, I split them then did the dims and didnt touch them after that.

What if I cloned them and placed a set in another layer, I created a master set from them but that shouldnt upset things.

What if their length changes, does the leader value change ?

Steve


(Pascal Golay) #4

I’m not sure what you did exactly, but the IDs that the dimensions were looking for were not the ones on the curves, so something changed the curves and changed the ID on them.

-Pascal


#5

Hi,

update since writing this below, its done it again, and I didnt alter the lines at all. Here is what caused it this time.

I wanted to check their lengths away from the busy difficult to select things area, so copied in place the curves and the dims, then move command and r2000,0 to get them to a clear spot, tried linear dim to get a rough check, then used the curve length dimension again on the lines for a few so I was seeing two of them in effect, happy with the figures, I then deleted that set, scrolled back to my set on the model and the dims there were ####.
Undid the delete and ### became numbers again !
Now stuck with a set I cant delete. So multiple undo to get out of that.

And now another occurrence, I have a line running across 5 stations each 100mm wide at datum, I need to see the distance from st1 to st2, then st1 to st3, st1 to st4 etc
I project a line onto fuselage for st1 to st5. Do the dim in crv command for this st1 to st5 line, and a figure appears.
Clone that line and split command it USING P FOR POINT at St4 so as to measure st1 to st4 on skin, and the st1 to st5 dimension goes ####

Do an experiment, curve dim a line, then copy in place, move it, split using p and get ####

How can I set the figures in concrete just incase it happens again ? (which it did)
In photoshop one can convert to raster the text.
I tried explode but the arrows lose their tip fill and go very thin.

I also needed to have the dimensions showing on the surface, now the fuselage side surface angles outwards as it heads to aircraft front. I was making dims with the arrows pointing fwds so they sat outboard of the surface.
Space decreed I needed to make two head the opposite way and of course the dimension sank within the surface. I exploded it and projected to surface but nothing showed.
I tried moving it on the z axis outboard of the surface but it must have needed many mm as it still sat within and visible when looking at the inside.

It would be useful to be able to create some which are like traditional dimensions, and be able to project to srf.

How can this conversion to ‘raster’ or whatever is needed to be able to stop the number from changing and be able to project to srf be done ?

I then need a command to sit such outside of surface, by an entered distance, to overcome the problem of surface part swallowing features as in other post where BringForward is tricky on a surface that heads in different directions.

Furthermore an auto BringForward associated with dimensions is required, as each and every dimension I plot, be it dim on curve or traditional dimension sinks partially or wholly, and I have double the workload as for each one I create I then have to go BringForward, and I am placing many many dimensions.

Steve


(Pascal Golay) #6

Hi Steve- make sure you split the copy and not the original curve.

-Pascal


#7

Hi,
definitley splitting the copy, sending you the video…

Also sent to europe.

It also does it as follows:-

  1. draw a line
  2. run the curve length command on it,
  3. copy in place the line
  4. move it r1000,0  (may be any distance, I use r1000,0  to move things out for working on them with no clutter !
  5. delete the moved item, the dimension in step 2 goes

Steve


(Pascal Golay) #8

What’s ‘it’? How do you know you are not deleting the original line? If you delete the lane that stayed put and not the one that you moved, do the numbers stay?

r1000,0 to move things out for working on them with no clutter !

Yikes… sounds like an excellent way to get confused…how about layers, Hide and ShowSelected?

-Pascal


#9

Hi Pascal,

it was the apparent copy, I say apparent as it appears all these yrs that I thought I was looking at the copy !

  1. draw a line
  2. run the curve length command on it, we see a leader arrow and a number
  3. copy in place the line, the copy shows as yellow (or so I thought)
  4. with the inplace copy now yellow and active use move command and r1000,0  (may be any distance, I use r1000,0  to move things out for working on them with no clutter !
  5. delete the moved item, the dimension in step 2 goes ####

I have just studied what happens with copy !
If one uses copy and clicks the line and drags out a copy, the ID of the dragged out copy is different to the ID of the line with dimension. If one uses copy>inPlace the yellow copy is not a copy as just now, its the original, so one thinks they are now with the copy when in fact they are about to move the original.

If I have a number of same curves, I would wish that the item generated by copy in place, that which is telling me its a copy by being yellow, IS A COPY ! If I have to then try and select each item below or above it until I find the copy I jsut made, which means referring to Object details, what a nightmare.

It will also lead one to end up having #### occur !

Simple fix then, make a cloned copy go yellow (selected), as do copies made in other ways with that command.

…as for the move, if I select objects, are you saying its possible to hide everything but these, work on them, create layers whilst doing so , add items, cut, do,some deep work !!! whatever…then get the hidden objects back.
If this involves finding what layers they are on, and selecting those layers, given the big problem I have of finding those layers in the layers palette, it would take me forever to find them and make all but those not visible.

There are times I need to go back to the source area, select a few more things and move them over. So that would mean turning layers back on, then off again, but if I turn them on, I have lost the careful selection I had made and need to go through the what layer is it on process all over again ?

I would need to see this as a video.

Steve


(Pascal Golay) #10

And how are you determining this? In fact the copy is not selected and the original remains highlighted.

-Pascal


#11

Hi,
you posted before my reply was up. see my discovery, based on the fact that copy and drag sees the copy yellow, I presumed copy in place also was yellow, have done so since day 1 rhino.

Steve


#12

Re ‘setting figures in concrete’: the quick and dirty way to bake a dim is by exploding it. The dim variable will be turned into a text block, and the leader and arrow or tick will explode into lines. Explode the text block and you will get curves to project. There are other ways to do this, some cool scripts out there as well of course.


#13

Hi,
I tried explode and wrote about it here somewhere, saying that the arrow head lost its fill and visiblity, the lines went very thin and I was unable to project the number to surface, I tried re-exploding it but still no joy.

Steve


#14

the text and arrow can be turned into surfaces for increased visibility.
I don’t know why you are unable to project the curves from the exploded text block. Common action, works on my Rhino no problem.
the lines can be given their own line weight.


#15

Looks to me like you are deleting the original and not the copy. Try clearing the selection and using _SelLast to move the copied curve.