Curve edge match doesn't match G2

This is the result of me matching on the edge in the attached file:

Anyone know what’s wrong?

curve-edge-match-problem.3dm (55.2 KB)

Hello - I’m not sure what you intended, or how you got here, but Match using the SurfaceEdge option matches to the surface, not the edge curve, in case that explains anything.

(i.e. if you want to match to the edge as a curve don’t use the SurfaceEdge option - edges are eligible as curves by default.)


Match can be used with surface edges as one or both input curves - but - the output will be a curve and the surface will not be changed.

Ok, but if I don’t click SurfaceEdge and switch MatchTo=PickPoint I don’t get any snapping.

This is really confusing, because originally I wanted a “match by closest point” like the “match surface” command has. Rhino tools aren’t very consistent, and thus very difficult to learn.

Hello - I agree that matching to the pick point is almost useless as currently implemented.

@eobet - a trick. Don’t blow me up, I’m not saying this is a proper solution, it’s a trick to get you going for now :
Start match, pick your curve.
At the prompt for the target curve, type SubCrv and Enter.
Then pick on some location near but not where you want the curve to end up and drag the subcurve back to the location, (Snaps work) where you want the curve to match.


1 Like

Maybe I’m missing something, but I would split the surface edge at the exact point were you want to match the curve. Then match to the edge segment.

Yes… it’s just that SubCrv avoids the extra geometry change. None of this should be necessary.


Is fixing the “Point on curve option” of Match on the heap?

Hi David - it is on the heap but not in a position, currently, that indicates it will be done soon. I will lobby.


1 Like

Thank you for the workaround! I will try this.