Curve display width

Is there a setting to get a similar display width as in V7?

While it looks very good in both V7 and V8, a bit thicker would be fine.
Also selected curves could look better in V8.

(I know how to set it in the shade mode settings, but e.g. 1 for curve width is different V7/V8. Also it’s per single mode.)

Hi Charles -

No, there isn’t a single setting to change this.
The way that curves are displayed in Rhino 8 is very different from how it was done in Rhino 7 and this new system is still undergoing changes. We have this issue on our list as RH-68900 - I’ve added this thread.
Thanks,
-wim

I also didn’t like the look of the curves in the WIP so I went to the advanced options, found Rhino.Options.OpenGL.WireThicknessScale and set it to 1.25. That seems to be close to Rhino 7’s look.

Dan

2 Likes

Thanks Dan

I searched for such a setting as well, but didn’t use good search words.
Now I have set it to 2, looks neat in here.

Hi Charles,

I just search for “wire” to pull up this option. It’s the only one that appears, which makes it even easier to find. :slight_smile:

Dan

I used curve, crv, OpenGL, GL, stroke, width.
Could have found out using OpenGL…

We have to remember that we changed it.
Otherwise it conflicts with new developments.

Yes, since Wim has it on the to-do list, we may find this adjustment redundant in future releases.

Or, that you might want to reset it to the default at some point.
-wim

1 Like

@Charles and @DanBayn please run TestDpiScale and paste the results here.

I’m interested to see what the DPI scale factors are on your computers. Here’s an example of what I’m looking for.

Command: Testdpiscale
Display DPI when Rhino started: 192
DPI scale: 200%
DPI scale factor: 2

Thanks

Screen resolution is 3840 x 1920

Befehl: Testdpiscale
Display DPI when Rhino started: 96
DPI scale: 100%
DPI scale factor: 1

Here are my results:

Command: Testdpiscale
Display DPI when Rhino started: 96
DPI scale: 100%
DPI scale factor: 1

Thanks guys; I made some tweaks this weekend but they would only affect higher DPI displays. I’ll keep poking away at this.