Curve Control Points Not Visible

Anyone else having this problem?

When I select a curve, the control points are no longer visible by default, neither can their visibility be turned on with F10 - so I can’t edit a curve via its control points, which I’m relying on for my current project.

This is occurring in Rhino 6.18, and I just checked Rhino 6.17 - in that version, the control points are only visible in the perspective window, not the orthogonal windows. I’ve tried this on two different PCs, one with NVidia Quadro, one with GeForce GPUs, same issue, both Win 10 Pro.

Anyone got a fix or a workaround please? I really need this to work today if possible.

Thanks,

Jonnie

Hi Jonnie - Could you make sure to try with display modes set to factory-default values -i.e. no blue names of display modes:
image
If that doesn’t do it, please post a sample 3dm file and the result of the Rhino SystemInfo command.
-wim

Hello Wim,

The display modes are not changed, I think it is a plugin causing the problem - I’m just trying old versions of the plugin and will report back shortly, thanks for getting back to me so quickly,

Jonnie

Hello again,

Right, it’s not the plugin, but the settings for Wireframe had been changed (I was expecting the display mode names in the right panel to go blue, but they dont - only when I’d tried old versions of the plugin did I come back to open the tree on the left side and see a load of blue names where there should only have been one or two).

The thing is, I have never changed those settings with Wireframe, because I use the control points for editing all the time. ‘Hide Control Points’ and ‘Hide Control Polygon’ were both ticked for some reason.

Depending on which computer I looked at, other settings had also been changed but I hadnt changed them.

Anyway, it’s fixed now and I can get back to work.

Thanks,

Jonnie