CSV File can't be read by GH in file path

Can somone please help me here? when I select my CSV file on File Path it doesn’t read my file and it only shows my file location and I don’t know what to do!

1 Like

looks like the drive letter is missing, like C:/Users…

Hi -
I just tested that here with a CSV file on the Mac:
image

Can you try with a different file and perhaps in a directory that doesn’t contain your username?
-wim

Hi

Thanks for your reply I have tried to used different files but it still gives me the same error :((

Hi thanks for your reply but Its because I was using my file from my download folder I have tired multiple other csv files but it doesn’t want to read my file :frowning:

Hi -
Please run the Rhino SystemInfo command and copy-paste the result here.
-wim

1 Like

Rhino 7 SR1 2020-12-8 (Rhino 7, 7.1.20343.09492, Git hash:master @ 350b20978b4fcd75493212fbd3c4248983612f86)
License type: Evaluation, build 2020-12-08
License details: Cloud Zoo
Expires on: 4427137-06-23

Apple Intel 64-bit macOS Version 10.14.6 (Build 18G7016) (Physical RAM: 4Gb)
Mac Model Identifier: MacBookAir7,2
Language: en-GB (MacOS default)

Intel® HD Graphics 6000 (OpenGL ver:4.1 INTEL-12.10.25)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: Intel Inc.
Render version: 4.1
Shading Language: 4.10
Maximum Texture size: 16384 x 16384
Z-Buffer depth: n/a
Maximum Viewport size: 16384 x 16384
Total Video Memory: 1536 MB
Graphics: Intel HD Graphics 6000
Displays: Color LCD (126dpi 1x)

Graphics processors
Intel HD Graphics 6000 (1536 MB)
Color LCD (1440 x 900)

USB devices
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
None

Third party kernel extensions
None

Third party plugins
/usr/lib/log/liblog_network.dylib

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
/Applications/Rhino 7.app/Contents/PlugIns/NamedSnapshots.rhp “Snapshots” 7.1.20343.1002
/Applications/Rhino 7.app/Contents/PlugIns/PanelingTools.rhp “PanelingTools” 7.1.20343.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhMaterialEditor.framework “Renderer Development Kit” 7.1.20343.1002
/Applications/Rhino 7.app/Contents/PlugIns/Displacement.rhp “Displacement” 7.1.20343.1002
/Applications/Rhino 7.app/Contents/PlugIns/RhinoRender.rhp “Legacy Rhino Render” 7.1.20343.1002
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Commands.rhp “Commands” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_OBJ.rhp “Import_OBJ” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_XAML.rhp “export_xaml” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/QuadRemesh.rhp “QuadRemesh” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_OBJ.rhp “export_OBJ” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RDK_EtoUI.rhp “RDK_EtoUI” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_SVG.rhp “Export SVG” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/MeshCommands.rhp “MeshCommands” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_DAE.rhp “Export_DAE” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_PDF.rhp “PDF Export” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_IGES.rhp “IGES Export Plug-in” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_SVG.rhp “Import_SVG” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/BlockEdit.rhp “BlockEdit” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Export_AMF.rhp “Export_AMF” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoRenderCycles.rhp “Rhino Render” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/import_DST.rhp “Import_DST” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/export_PLY.rhp “PLY - Polygon File Format Export” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/Import_AMF.rhp “Import_AMF” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoCycles.rhp “RhinoCycles” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/RhinoDLR_Python.rhp “IronPython” 7.1.20343.9492
/Applications/Rhino 7.app/Contents/Frameworks/RhCore.framework/Resources/ManagedPlugIns/GrasshopperPlugin.rhp “Grasshopper” 7.1.20343.9492

The problem is that I have received my csv file from my tutor and its definitely the right kind of file and as they mentioned my csv file is not open in any other application on my Mac I have also tried to export another file with up to dated version of excel but still has the same problem.

unfortunately very new learning grasshopper but do you know if there is any other way that I could load my data?

This seems quite strange.
When you want to see what’s on a file you can use a sort of text editor. I use Notepad++ on Windows and it seems that there are sort of notepad in Mac (coteditor ?). If file can’t be read with that you have a problem that is not a Grasshopper problem.
So please show the look of your file in a text editor.

ListofSchools_LAEI2013.csv (281.8 KB)

this is a sort of file I’m trying to use

For sure it is a very classic file and it works very well in Windows. So I can’t help more, I have no Mac.
image

So it doesn’t seem to be a file problem.
On your MAC
Can you open the file you send on a text editor ?
On Grasshopper is there an error message on the red component ? Zoom on it you must have a little message
image

Hi Laurent thank you for your comment this is the message I get Screenshot 2020-12-24 at 09.50.37

Hello

before asking to the developer, I want to be sure of one thing.

Can you suppress this component and add another Read File component.
because you could implement your own parser and if wrong it will give you this message
So if you right click there “Parser…”
image
you must have that

If not it is not good !!!

sure here the message I receive when I press Parser

Thanks for looking at that.
@DavidRutten the CSV reading problem seems like a bug associated to MAC! Can you help ?

1 Like

I’m also on mac and have been experiencing this exact same issue since upgrading to rhino 7, in sessions that were working previously in version 6.

Just wondering if this has been solved, or if there’s a better work-around than copy/pasting the contents of the .csv to a panel?

Hi there,
same error on my side…

Hi, just bumping this again and confirming I am seeing the same issue on 7.6.21127.19002 and 6.34.21034.07002.

If this is a confirmed issue, would it be possible to get a link to the bug tracker item for this? If it is not confirmed/reported, please let me know if there’s any documentation still needed beyond this thread and this thread. Thanks!