Conversion of nurbs model to autocad incomplete

Hey guys&gals,
I need some help, trying to send my producer who works in autocad 2020 a large set of nurbs model parts to machine.

Saving as DWG -solids 2007 surfaces as solids,
Loosing all cirved surfaces if it opens at all.
And if then they cant work on the model.
Anyone a tip? Either from the export of import side?

This should work - can you post an example object as a Rhino file, or send to, to my attention, with a link back to this topic in your comments?


jup, ill send it to you by email! thanks!

testfile rhino to Autocad.3dm (316.3 KB)

sorry , new at forums so might not have replied correctly, thanks for your help!

Hi Thomas - is this correct?

testSolids.dwg (87.8 KB)


yep thats it, at least when i open it in rhino,
dont run Autocad 2020 myself,
so whats the right setting to get them to open it such?
Thanks again

Hi Thomas - does my file behave differently in Rhino from the ones you export? I believe my only change to ‘2007 Natural’ was this:


Tried that setting and they still tell me they can see the object in autocad but cant work it. Does that seem strange?

Hi Thomas - I guess send them my file - if that works, I’ll just export my scheme and you can try that.


Sweet thanks!! Ill give it a go with them!

They tried but still cant open it properly, any chance you have a tip on specific opening settings on the autocad side?

@scottd @mary - can ideas on opening DWG solids on Autocad? Are there special settings?



my producer thinks its due to “errors” in the rhino models precision.
and indeed when I zoom in the line-end don’t meet accurately.
however the circle I drew on for check is 0.0000001mm.
and the model shows and reads as a closed polysurface.
is there a way to merge these “flaws” and thus have a clean model?

thanks for your ongoing help!

No, it’s that DWG SUCKS. Use an actual 3D format like STEP or IGES, AutoCAD can read them.

If you send the the file someone might be able to figure out what can be done to make the DWG work, but really it’s just a horrid legacy format to avoid.

1 Like

okay so Step should work as an import towards autocad?
the producer keeps telling me he cant open them, or they open empty. never had that problem before.
thanks for your feedback

I don’t know if it can read STEP but it can read IGES.

Hi Thomas - try ShrinkTrimmedSrf on your object before exporting. The trimmed faces are much smaller than the underlying surfaces, which can cause problems.

@thomaslaurens another thing I notice is that your file tolerance it .01 mm . Evertthing still closes up if I change to .001, but in general it might be more reliable to model at .001 for export.


1 Like

keep getting these pics from the guys on my producers end.
not sure i can actually get my rhino drawing precise enough to avoid these minute glitches?

Hi Thomas - if this is with the faces shrunk (?), try exploding the object, change file tolerance to .001, Join, make sure it is closed and re-export. Your model looks fine - the edge and vertex tolerances seem just fine to me but try with tighter unit tolerances in Rhino.

But Jims suggestion of Step if a good one, or possibly SAT format.


1 Like