Control Point Alignment v6

unhandled

(Adam Hollis) #1

I’m experiencing an odd behavior in a new file I’m working on.

Base File is a DXF import, but the lines i’m working with are new additions. My end control points are “floating” off of the line. when I try to snap end-points together from two lines, the highlighted line jumps around.

Never experienced this on v5, and haven’t noticed it in any other v6 files. Image attached. Could it be a video card issue? I can’t post the file publicly, but will send to tech@mcneel.com

Windows 10, current
i7 7700k
gtx 1080
32gb ram


Snapping appears to be offset/ object handles not good
(John Brock) #2

Most likely your file is too far from the world 0,0 origin.
Try moving everything back so it’s close to 0,0

Any better?


(Adam Hollis) #3

Nope, same issue. It appears to be related to the GPU Tessalation setting. Off and it’s fine, on, and I get floating points. What does GPU Tesselation do? Should I be grumpy that i can’t check the box? :wink:


(Adam Hollis) #4

Actually, scratch that. it worked for a second, then went back to being crazy…


(Adam Hollis) #5

here are 3 different zoom levels on the same section, AA is off and Tesselation is off. The area in question is about 300mm from 0,0,0 as the crow flies.

you can see that the lines jump around, and I’m having issues joining into a closed curve.

to be fair, this is a pretty extreme zoom, but I never experienced this at any level in v5, and i’m very anal about point precision.


#6

I still suspect you might be far from the World origin. In the status bar, you have your coordinate display set to CPlane - what happens when you change it to World?

–Mitch


(Adam Hollis) #7

Here are some additional screens with a line intersection moved directly on to world 0,0,0.
In the top view, you can see that the end control point of the lower line is snapped to the end of the upper line, however the lower line itself is not being drawn consistently. the first image and the second image are 1 mouse wheel click apart in zoom.


(Pascal Golay) #8

Hello - can you please upload an actual file with the views and geometry that you don’t like?
thanks,

-Pascal


(Adam Hollis) #9

Can you receive it at tech@mcneel.com? i can’t post the file publicly.


(Pascal Golay) #10

Hello - yes. tech@mcneel.com is fine if it is specific to one file - is that the case? You don’t see this in general?

-Pascal


(Adam Hollis) #11

Here is a stripped version. I’ve cut and pasted into a new file, and rebuilt/re-drawn the lines repeatedly. and re-generated from surface, so i believe it’s a global issue, not just this geometry.mcneel_support.3dm (33.5 KB)


(Pascal Golay) #12

Thanks - here’s what Rhino tells me about the curves:

Geometry:
Valid curve.
Line
start = (-41.8402,-8.0547,0.0000)
end = (0.0000,0.0000,0.0000)
domain = 2899.9739 to 2942.5630
line length = 42.6084

Arc
start = (0.0000,0.0000,0.0000)
end = (-5.7288,24.3895,0.0000)
center = (-202.6229,-34.7262,0.0000)
radius = 205.5771
angle = 6.98686 degrees

And here’s what it looks like on my, admittedly tiny, laptop screen as the file opens, view maximized-

Can you run the SystemInfo command in Rhino and post the results here?

-Pascal


(Adam Hollis) #13

Rhino 6 SR2 2018-3-6 (Rhino 6, 6.2.18065.11031, Git hash:master @ cd4fa1dcdec31cb58baacef0855771173af7196f)

Windows 10.0 SR0.0 or greater (Physical RAM: 32Gb)

GeForce GTX 1080/PCIe/SSE2 (OpenGL ver:4.6.0 NVIDIA 391.01)

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 8x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: Height

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 2-23-2018
Driver Version: 23.21.13.9101
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 8 GB

C:\Program Files\Rhino 6\Plug-ins\Commands.rhp “Commands”
C:\Program Files\Rhino 6\Plug-ins\WebBrowser.rhp “WebBrowser”
C:\Program Files\Rhino 6\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 6\Plug-ins\RhinoScript.rhp “RhinoScript”
C:\Program Files\Rhino 6\Plug-ins\RhinoBonusTools.rhp “Rhino Bonus Tools”
C:\Program Files\Rhino 6\Plug-ins\export_ACAD.rhp “AutoCAD file export : export_ACAD”
C:\Program Files\Rhino 6\Plug-ins\IdleProcessor.rhp “IdleProcessor”
C:\Program Files\Rhino 6\Plug-ins\RhinoRender.rhp “Rhino Render”
C:\Program Files\Rhino 6\Plug-ins\rdk_etoui.rhp “RDK_EtoUI”
C:\Program Files\Rhino 6\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 6\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 6\Plug-ins\Alerter.rhp “Alerter”
C:\Program Files\Rhino 6\Plug-ins\RhinoCycles.rhp “RhinoCycles”
C:\Program Files\Rhino 6\Plug-ins\Toolbars\Toolbars.rhp “Toolbars”
C:\Program Files\Rhino 6\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 6\Plug-ins\Displacement.rhp “Displacement”
C:\Program Files\Rhino 6\Plug-ins\Calc.rhp “Calc”


(Pascal Golay) #14

Hello - thanks, -one last thing - can you un-check GPU Tesselation in Options > View > OpenGL page and see if that makes a difference?

-Pascal


(Adam Hollis) #15

no change


(Pascal Golay) #16

OK, thanks - you’ll want to set that check box back on. I’ll let this sit for the weekend and see if I can make it look ugly on my desk machine in the office, it has an NVidia card as well. However the upshot, I would say, is that the geometry is not off.

-Pascal


(Adam Hollis) #17

Alright, Thanks for looking into it.


#18

I can get them to look like that here…

image

However, before you think I’ve found the problem, look what I had to do to get it to happen…

image

That means that the little square you see is only 1/100,000 mm, i.e. a ridiculous zoom-in level. At any normal zoom level it looks fine. The extracted end points also select with SelDup, so the curves themselves are fine as far as I can see. Must be something with the display then… I’ve got a 780 here, but I’m still on 390.77 (next-to-last) drivers.


#19

I see the same thing. V6 is at least 1000 times less accurate when you zoom in than V5.

With this geometry in V5 I can zoom in until the entire viewport measures 0000000 mm from corner to corner - the endpoints of these lines are still accurately displayed at 0,0

When I zoom in on the same geometry in V6 the display of the line endpoints will start lose accuracy and jump around when the viewport measures only 0.0002211 mm across. That means you can zoom in at least 1000 times farther in V5 and still get an accurate display.

And as a side note V4 was even more accurate than V5. In V4 you can zoom in on these endpoints to the point where display starts to degrade and then measure corner to corner of viewport and it measures 8.49143e-12 mm across.

It looks like every new version has degraded the users ability to zoom in and inspect what is going on accurately.


(Abraham Wechter) #20

" the line endpoints will start lose accuracy and jump around when the viewport measures only 0.0002211 mm across"
Hard for me to understand why this is significant for most of us using Rhino. Can you please explain? From my experience if I have to zoom in this tight I should be looking at my modeling tolerances, not needing to visually inspect really tiny bits.