Contour Command only selecting a few floors

I am having trouble with my contour command as only 3 breps out of the 20 are closed. Not sure how to resolve this.


would you mind attaching the GH file with internalized geometries? :slight_smile:

It seems that the breps are all closed now after i restarted rhino and grasshopper 2x. Is this a bug i should be concerned with?

Attempt 3.gh (49.9 KB)
Residential concept mass 3.3dm (230.4 KB)

This is one hell of a mess. What are you trying to achieve? I can help you a little bit

I was literally just trying to create 20 more floors above my base script using my contour command but it seems to be registering now as all 20 breps are closed instead of only 3

I am also trying to create a façade script so it is a bit messy right now haha, I do apologise

No problem! It seems you have some troubles with your tree structure, in the facade script. You have 82431 curves at some point…

I am still new to this as the script I am modeling is from a YouTube tutorial. Is the responsible for why my pattern in the facade is selecting the whole geometry?

sorry I dont quite understand your question

For some reason, My pattern has been selecting the whole geometry as one pattern instead of a select few. Is it because i have so many curves in my existing curves?

You are not getting the results your are expecting because you are inputting DataTrees to the Region Difference components (note the dashed lines).

If you flatten these inputs, you will get the results you expect but your file that was slow to solve gets even slower.

If you examine the inputs to the Region Difference components you will see that there are many duplicated curves:

After culling these duplicate curves, things work as expected in seconds instead of minutes:


Also note that the third Region Difference has no effect (80 curves at input A → same 80 curves at the output).

Attempt 3_re.gh (58.3 KB)


Edit: One curve is referenced from the rhino file posted above:


Edit #2:
Was a bit short on time earlier today. Had some time later to examine your code more closely. Better to fix the code causing the duplicate curves instead of culling them.

Changed this code:

To this:


Note that now the output is a list instead of a tree (solid line).

You had this identical code block 2 times in your file so I combined them into one block using trees:

Removed the code for culling duplicates as it is not needed now.

Also changed this part of your code that generates the random numbers for your scale factors:

To this:


Even though the input to the Random is named “Range”, if you hover over it you can see from the pop-up that it is expecting a Domain.

Re-arranged some components to make the code more readable and enabled the components you had disabled.

Now it produces this output:

Attempt 3_re2.gh (52.6 KB)
All geometry internalized in this GH file.

-Kevin

Thank you Kevin! This helps a great deal

I also managed to find the issue where my Multiplication command and geometry command were causing duplicate values where I only needed the multiplication result. I am currently trying to link the façade script to my custom geometry script at the moment. Encountering some issues. I can attach the script if you willing to assist?

If you upload the script and describe what problems you are having, I will take a look.

-Kevin

Facade of Design updated.gh (36.9 KB)
Residential concept mass 5.3dm (1.1 MB)

So the script for my facades have been linked successfully, however my windows seem to be inverted outwards on certain facades of my building. I have no idea how to resolve this at all. And Just to make my model look neat, I have been trying to offset the facade slight away from the floors

it happens because the direction in which the cells are extruded is set to +Y, so all your curves are extruded in that direction

(this is taken from the top of your Def, but is the same for other areas)

1 Like

Will a unit vector solve this issue on displaying my windows in the correct direction on all my facades?

this might work, but it’s a patch :slight_smile:


Facade of Design updated_Re.gh (45.6 KB)

if you want the windows to be oriented in the opposite direction, just delete the Reverse Vector component here:

Thank you, This helps a great deal!