Compiling GHPY compiler doesnt seem to work for me

I am following the tutorial on:

Using the second method for advance compiling.
I have compiled a ghpy with multiple components.
I have dragged both the sample ghpy and my own ghpy into gh.

Sample ghpy here:
https://aws1.discourse-cdn.com/mcneel/uploads/default/original/3X/6/f/6f0cbfe8427e34062c6adff30829b47f447e08e4.ghpy

They both fail , error message is missing the ‘axes’ module for sample ghpy, and my own module for my ghpy.

using:
rhino 6.10.18311.20531
gh 1.0.0007

1 Like

@Alain, @stevebaer, do you know of any particular changes in 6 SR10?

I’m not aware of what changed between 6.0.16313.01411 and 6.10.18311.20531 but I can take a look.

I don’t know of any changes made to GhPY compiler at all beyond your work @piac.

Hi @yun.sung

I just checked the file that you posted, and it works in Rhino 6 SR 23.
Can you please update to the latest Service Release, so that we can be sure to be using the same codebase?

Thank you,

Giulio


Giulio Piacentino
for Robert McNeel & Associates
giulio@mcneel.com

My computer and software is determined by my company. I will check to see if I can update them. Cheers and thanks for all your help everyone.

1 Like

Thanks. Please let us know if you encounter any problems updating.

Giulio


Giulio Piacentino
for Robert McNeel & Associates
giulio@mcneel.com

Just for more info: I feel it is some pathing problem.
Here are some screenshots i took:

image

IMPORT NOTE: I am creating assemblies for my company to use, so I need to keep my rhino version the same as what everyone else is using. Therefore I cannot update my rhino version to resolve this…

Additional: I read somewhere that it could be some problems with having multiple versions of ironpython. so i have the ironpython that grasshopper uses, and the iron python that is downloaded to c drive. lets say I uninstall the C:/ironpython. How would I use the ironpython.gha to compile the ghpy then? Since there is a permission error when i tried it last time. What is your workflow?

I have same issue.

ouch now its done something to my grasshopper
GH is acting very slow now for some reason … may need to reinstall fresh copy

SOLVED:
You have to go into rhino and use “rhino python editor” to compile (i.e. run main.py), not your own iron python or grasshopper python editor. This works.

3 Likes

Many thanks for your solution. It has worked for me, but I was faced with a different problem.
When I drop the .ghpy file into the Grasshopper’s canvas, I get the following error:

I just edited the sample code from Giulio a little bit. I really cannot understand why I get this error. Can someone please help me?

Here the possible error location:

image

Test.py (2.8 KB)
TestCompiler.py (56 Bytes)

What did you do? Knowing that will probably solve the problem.