Collada (dae) file - Cannot export object name or layer, only mesh id

While doing some work for a third party app, I found that I cannot export layers nor object names from my models. When I import the dae file I get only a mesh id.
Furthermore the file seems to embed the views as well.


Hi Fabiano,

I suspect, based on my own experimentation after reading your post, that the objects in your model are not meshes to begin with, is that correct? Under the hood, Collada export uses object render meshes (for non-mesh objects) so it can preserve the block instance/reference concept in the output file. My guess is that I’m not using the parent object attributes to associate a name with the mesh. I’ll look into that. In the meantime you can select the objects you want to export and run ExtractRenderMeshes. (This adds the meshes to the doc and it does use the parent attributes so the resulting mesh has the same name.) Esc to deselect. Run SelMesh and export the selected objects. The resulting file will have object names as a "name " attribute of a geometry node.

I was not able to see how Collada respresents layers in my documentation so I know that it’s not implemented. Do you have a very simple file that exhibits how layers exist in a .dae file? A single mesh on a layer and a couple of additional layers that have no objects on them would be good.

Is embedding the views in the file a problem for you? Are you suggesting we should not include them or it should be optional?


Hey Tim.

My model is a bit of both, mesh and b-spline surfaces, but I do mesh them all before shipping.
Unfortunately your suggestion did not work. It still outputs the some id-number instead of its name.

To be honest I think this is the 1st time I had to use Collada format, but the client is asking specifically for .DAE file.
To mimic what I am getting, just create a box, mesh it, name it and export as .dae. Open in Blender or in my case AR Studio and you will see the id for name.

For the views I guess it is just cleaner to remove them when you tick “Export Geometry Only”.

I just tried to export from the WIP (5E397w) and the name does work on to Blender, but not to AR Studio…

Hi Fabiano,

Here’s a very simple file that demonstrates what I mean. Untitled.dae (10.1 KB) You can use a text editor to view it. We use the Rhino object id as the id because it is unique and can be used throughout the file to easily make references between nodes. The object name does not need to be unique in Rhino. AR Studio (what is that, btw?) must be using the id attribute as a name and not the name attribute itself. The former is required, the latter is not, so that is sort of understandable. I’ll look into implementing ignoring views if the geometry only check is checked. Generally speaking, I think those checks mainly apply to .3dm files. Any of plugins I’m responsible for have their own dialog to address options like that.


Interesting. I managed to convince the client to use FBX for now, but still…
ARStudio is a Facebook app to make AR masks.

Thanks for the support.

1 Like