Cluster Output Description not showing

I have created an evaluation cluster which produces around ten outputs. I have used the nickname in each output to differentiate them and make them vaguely meaningful.

I want to use the output descriptions to show a fully meaningful explanation of each when you hover over the cluster output in the calling program. The description shows when editing the cluster, but doesn’t when in the calling program. I just get the description from an upstream component within the cluster. I have tried closing and reopening the program (which helps with getting the names to show correctly) but that doesn’t help with the descriptions.

Bug or user error?

Do you use output and input components inside your cluster?
There you can also write description by double clicking on them.

This is the proper way and not by right-clicking on an input/output of an already created cluster.

Hi Ivelin,

Exactly…
A simple (and not particularly important) example -
Inside cluster I have added a description to the output:


In calling program I don’t see my description, I see that of an upstream component in the cluster:
image

Regards
Jeremy

1 Like

hmm interesting, never experienced that before.

Very long standing bug. When you edit cluster input/output components, it has no effect outside the cluster. Solution is to add new cluster inputs/outputs, change the external wiring to use the new outputs instead of the old, then remove the old. UGH. It’s ridiculous. :frowning:

2 Likes

Yep, possible. :blush:, I found out that I can set description for input/output components a week ago, by accident :smiley:

Thanks for the workaround. Let’s hope the commitment to documentation for GH2 inspires a fix…

I’ve had this problem recently too after changing a cluster output’s name and nickname and description while editing an existing cluster. After saving the cluster edits, the changes to the output didn’t show on the cluster in my definition.

I couldn’t figure out why it was happening, but my solution was to edit the output, copy paste it, connect the copy and delete the original. That fixed it. Seems like a bug to me, but maybe I’m committing the same user error you are?

That’s the same work-around that I described above. It’s an old bug, not a feature or user error.

1 Like