Closed curves will not extrude properly


#1

not sure why this is happening


#2

Hit F10 and start moving those CVs to check where the line overlaps it self. It can be closed and overlap at the same time.


(Brian James) #3

If you have overlapping control points, ExtractPt of the ctrl pts followed by SelDup can show you where the issue is. Post the crv if you can using the Export command to save just that selection if that doesn’t help.


#4

You can use this python script to find and mark where your curves self-intersect:

SelSelfIntersectCrvs.py (1.2 KB)

–Mitch


#5

thanks! will try these and report back today


#6

ok well none of those worked for me, here is the file if anyone wants to tryhorse.3dm (48.3 KB)


#7

Scale it up by factor 10. Then it works.


#8

you can also up your absolute tolerance in the preferences, just add a few 0’s something like 0.0001
but generally scaling curves to - or working in such a small area when the working space is far larger will always cause you problems.


#9

AHA SO problem was just scale of my object or tolerance