Clipping Planes Not Working

Ok, I downloaded the new WIP to try out the GPU Tessellation. Before this update, the Clipping Planes worked just fine. Now none of them work, including a newly added one. What I do see is this. Wireframe mode, in the area within the clipping Plane, the background’s color changes slightly, very slightly, but noticeable. My video card is a NVIDIA K2000, driver version 369.26 running a Dell T1650, Windows 7 Pro, 32 gb ram, blah blah blah. It was working fine before the update. After seeing this issue, I restarted Rhino, loaded the same file, same thing, loaded a different file, same thing. Just thought you should know!

Does the GPU Tessellation feature have anything to do with this or are clipping planes not working independent of the GPU Tessellation setting?

I also noticed you were having weird display bugs with points in a different post that went away after rebooting your computer. Did you try rebooting your computer?

Nothing to do with it, sorry

I’m sorry, that was my next thought! I’m going to reboot it now.

Ok, reboot the computer. Same thing!

Could you provide some screenshots of what you are seeing? Does this happen with every model?

The other issue was with the edit points. That seemed to go away once I restarted Rhino but without rebooting so this is a completely different issue. I somewhat wished I didn’t bring that one up.

Here it is with the box checked.

Here it is unchecked.

Here’s a brand new on on a new layer not checked


Is that a point cloud? What happens if you draw a sphere; does that get clipped?

Yes it is a point cloud. A simple sphere works great.

BTW, this is a SS from V5 with the point cloud. The previous WIP looked the same except I didn’t use a two color background.

Here’s the sphere.

I have thought about updating my video driver but I’ll wait until I hear back on this before doing so. Also I have to leave for the day so we can continue this tomorrow.

Is there anything else you would like me to try?

Not right now. Improper clipping of point clouds is a bug that I can repeat and have added to my list to fix at
https://mcneel.myjetbrains.com/youtrack/issue/RH-39202

Thanks for the update kind sir!

RH-39202 is fixed in the latest WIP

1 Like