Clipping planes causing display glitches


#1

Take a look at the video attached. When I add a clipping plane to the scene, in the perspective viewport, the name of the viewport will disappear. As soon as I delete the clipping plane everything works as expected.
https://www.dropbox.com/s/uh63r0z1akcb6b9/Rhino%20clipping%20planes%20Mac.mov?dl=0
Rhino clipping file mac.3dm (3.0 MB)


#2

Software information

Software versions
Rhinoceros version: 5.4 WIP (5E334w)
Rhinoceros path: /Applications/RhinoWIP.app
IronPython version: 5.1.2015.131
WIP expiration: 19 January 2018
Language: en-ES (MacOS default)
macOS version: Version 10.12.6 (Build 16G1036)

Plug-ins
None

Third party kernel extensions
None

Hardware information

Computer hardware
Hardware model: MacBookPro11,3
Processor: Intel Core i7-4850HQ CPU @ 2.30GHz
Memory: 16 GB
Architecture: Intel 64 bit

Video hardware
Graphics: NVIDIA GeForce GT 750M 2048 MB
Memory: 2048 MB
Screen size: 1440 x 900
Displays: Color LCD (221dpi 2x)

USB devices
Apple: Card Reader
Apple Inc.: Apple Internal Keyboard / Trackpad
Apple Inc.: Bluetooth USB Host Controller

Bluetooth devices
None

OpenGL information

OpenGL software
OpenGL version: 2.1 NVIDIA-10.17.5 355.10.05.45f01
Render version: 2.1
Shading language: 1.20
Maximum texture size: 16384 x 16384
Z-buffer depth: 24 bits
Maximum viewport size: 16384 x 16384

Implementation settings
Use texture compression: No

Appearance settings
Antialiasing: 8x
Mip map filtering: None
Anisotropic filtering: None


(Dan Belcher) #3

Hi @jespizua

Thanks for reporting this and for submitting a video and a file. Unfortunately, I’m not able to reproduce this on my end with your file. The main difference between our systems is the version of macOS. I see you are running:

macOS version: Version 10.12.6 (Build 16G1036)

whereas I am on:

10.13.3.

So I went ahead and test on macOS 10.12.6, but I still could not reproduce this. Frustrating. It looks like you are reliably able to reproduce it with any file.

Anyone else seeing this one?


#4

Hi @dan, thanks for taking a look at this. I confirm this is still happening using 5.4 on both my machines, 10.12.6 and 10.11.6

It happens here when I move the clipping plane using Gumball, if I use regular move tool everything is normal. So, let’s make it clear:
1 Create a box in the perspective viewport
2 Create a Clipping Plane in the same perspective viewport
3 Activate Gumball and select the clipping plane
Each time I select the clipping plane having Gumball activated the name Perspective will disappear from the viewport, as soon as I deactivate the clipping plane everything come back to normal.

Can you reproduce it?


#5

yeh I see this too, it happens in any viewport you have active with a clipping plane and gumball active, the viewport names disappear, when you deactivate the clipping plane they reappear, no biggie but something not quite right


(Dan Belcher) #7

Not sure why your first explanation didn’t work for me. Your second listing of steps allowed me to reproduce this one. Logged as RH-44807. Sometimes it takes “show” and “tell.” Thank you for being explicit.