Clipping plane bugs

rhino5
unhandled

#1

I have a bug issue about a clipping plane which seems like it is always switched on. I cant turn it off because I cant find the clipping plane.
Even if;
1- I turned on all the layers,
2- Checked the “Clippin Plane” in the Display TAB
3- Unhidden all the objects,
4- Unlocked all the objects,
5- SelClippingPlane (No added selection),
6- DisableClippingPlane (Selecting all the extent viewport but no target found)

In conclusion; my model is still cropped by a clipping plane in half at XZ-plane and coud not find any solution about how can I turn this clipping plane off. This is a serious bug that I’ve ever seen at the first time. If anyone has ever experienced please let me know and spread the solution if there are any.

I am using Rhino 5 SR12 64-bit

Thanks, best regards.


(Pascal Golay) #2

Hi Bora - please post your model or send to tech@mcneel.com

thanks,

-Pascal


#3

You might try running this script and see if it gets rid of the clipping plane…
(Save script somewhere, ! _RunPythonScript, browse to script, Open)

TestDeleteAllClippingPlanes.py (540 Bytes)

–Mitch


#4

What display mode were you in when looking for the clipping planes? Did you try Wireframe?


#5

Thanks @Helvetosaur for your script. Although I’ve tried your script, it still says “no clipping planes were found”.

The problem might occured while I was just working with the blocks, I might opened a clipping plane in a block edit active window. Actually I saw my clipping planes only when i select all command but those clipping planes were disabled furthermore I erased the ones that were in the blocks.
But the thing is these clipping planes were not in the origin of the xz plane which my model cropped in just only the y-axis which is 0.
These ones in the block that I mentioned were located at the furtherside from the 0 axis so I have actually no problem as my model is not affected by these embedded clipping planes in the block. I have a problem with a clipping plane at the 0 y-axis that I think i didnt created it accidentally.

As I remember this problem was occured after I save the block when i forgot to deattach the clipping plane from it.
So the program might automatically created an indestructible one at the xz plane at the origin of “0” y-axis.

I attached the related file if you are not sure that I’m missing something or not… :slight_smile:

clipping_plane_bug.rar (2.3 MB)


#6

Every display mode is the same @AlW, contrasting to that if you look at the file in the above file that i shared, in the top, right and some other views you can see the whole model due to I’ve only checked the perspective and a back view.

I think there are no other way to fix this, besides of selecting all the model by “select all” command and copy to a new file if it doesnt prevent me to select the other side of the clipping plane that I cant see… :confused:


(Rodrigo Bárcena) #7

Bora, I got back to you with an alternative fix, did you get my mail and attachment?
Delete all viewports but one that keeps the right display, then right click 4-view twice.


#8

Hey Rodrigo,

Ah I fixed it now thank you very much. Now it gets me on the right track. Nice to know that it is being fixed by this way.

I think it is a bug between the blocks and clipping planes.
Actually it is my mistake that I should never saved a block with a clipping plane in it with unconciously… :slight_smile:

Thank you very much again,
Best Regards


(Wim Dekeyser) #9

Just a few things that might or might not be related…

I opened the file in the RH6 WIP and purged the file and then organized all objects on layers by object type. One thing that I noticed here was the existence of control objects. I saved the file again in RH5 format after deleting those control objects and opened in RH5. At that point I could see the entire model. What creates these control objects? Plugin?

But shading it ‘drowns’ the boat:


… indicating that there might be an object that is creating a ‘leaking’ render mesh (but no time to look further into that aspect now).


#10

Hi @wim,

Actually i’ve thought managing to delete the unnecessary parts of the model to keep the file size as low as possible.

But looks like its not completely deleted and program might keep some or all the control points of the deleted models.
Those in the picture were deleted.

Thanks for lookin it in a different perspective… :slight_smile:


#11

Having the same issue as Bora, Rodrigo, what exactly is the alternative fix and what is this with the deleting viewports and right display?


(Rodrigo Bárcena) #12

@Zalie

I think this is the message I sent to Bora back in the day* :

I don’t really know what could have happened, I should do some more research about that…
I think I fixed it using this trick: close all viewports but one that shows all surfaces correctly, maximize it, and then right click twice on the 4-viewport icon. that should bring it back to standard, see attached.

  • keep in mind that this thread is over 1 year old…

(Direnc) #13

I had the same issue with Rhino Wip (6.3.18072.11251, 3/13/2018)


(Wim Dekeyser) #14

Can you be more specific? You don’t see the Clipping Plane after you have created one? Does this happen with a simple box in a factory-default template file?


(Direnc) #15

A Clipping plane disappeared that I have created earlier, all layers were visible and there were no hidden objects.
After reading this topic I have set my viewport layout to 4 viewports again, It came back.