Cleanup After a trim


#1

In the attached file, I have two 3-point curves that I have used Sweep1 on.

Then I trimmed using a circle…

This gives me an odd result at the tip. How can I clean up the surfaces to conform to the circle?

Trim Problem.3dm (3.0 MB)


#2

I’d usually do the work in the curves, at a minimum it seems like you wanted tangency if not continuity in the first place. Otherwise blendsrf might work? I’m on the wrong machine right now or I’d check your file.


(Pascal Golay) #3

Looks like you left out the two tiny surfaces at the tip there.

-Pascal


(David Cockey) #4

I assume you trimmed it with a circle in Top view with ApparentIntersections=Yes. If so the edge of the polysurface conforms to the circle to within 1.2e-06. The intersection of the four surfaces which make up the polysurface are close to the tip - is that what you are calling the “odd result”? That originates with the polysurface before trimming. Post the curves used to create the surface if you need help in determining why it is a polysurface rather than a single surface.


#5

Here’s the same with the curves.

It was created as you describe.

Yes, I wondering why trimming with a circle creates an edge with multiple segments that do not merge.

I’d live with it the way it is if this not going to cause some odd problems downstream.

Trim Problem.3dm (79.9 KB)


#6

The apparent Intersection option doesn’t apply to trimming surfaces. That option works only on trimming curve with curve

The reason is the surface is not big enough for the circle to fit inside its boundaries. So extending the surface would be the first step to avoiding the problem

Your loose tolerance may also eventually create problems

In the enclosed file showing a way to do what you are trying to do that is more accurate and simpler. Instead of trimming and extruding the edge just extrude the arc and trim both surfaces against each other
Trim-NoProblem.3dm (59.7 KB)


(David Cockey) #7

This is incorrect. ApparentIntersection option of the Trim command works when trimming surfaces with curves. Try Trim with ApparentIntersection=Yes to trim a surface with a curve which is not on the surface. It works.


#8

Try the same thing with ApparentIntersection=No

The Help file has a pretty good explanation of the rules of trimming surfaces with curves. I highlighted the relevant parts: