CheckNewObjects disables startup splash page

I put CheckNewObjects in my startup script under File->Properties->General->Run these commands on startup. That way I don’t forget!

It asks me on startup if I want to check new objects. Well, yeah, that would be the purpose of putting CheckNewObjects in the start up script…

But that question also means that the splash page that would otherwise show up simply disappears. I would prefer it did not because presumably there might be something useful on it for me – otherwise why have it at all?

Is there a way to disable the prompt or can the system be fixed so the prompt doesn’t end the splash page prematurely?

Try entering it this way:

_-CheckNewObjects Check=Yes _Enter

Should fix both of your issues.

-Kevin

Thanks! Worked perfectly!

In theory at least one shouldn’t need to do this. CheckNewObjects is set to be “sticky” between Rhino sessions, so setting it once to Yes should do it, you do not necessarily need to call it on every start-up. Of course, doing that won’t hurt anything either…