Cap surface isocurve to respect cplane not world

is this possible to set this behavior? or some command which would orient isocurves according to cplane not world?

1 Like

Hello- no. Here’s a py that lets you set it any way you like after the fact though. (7.1 KB)

@Rhino_Bulgaria @ivan.galik I tuned up a couple of things here…

To use the Python script use RunPythonScript, or a macro:

_-RunPythonScript "Full path to py file inside double-quotes"

Also, @ivan.galik , @Rhino_Bulgaria - why the current CPlane? I can see maybe needing to align the UV for texturing or some special ‘on the spot’ need, but in general, why do you care?


1 Like

maybe for future consideration? i think it would be expected from a user when he is working in certain cplanes that operations like these respect it. what do you think?

1 Like

Wow, this is an amazing tool! It deserves to be included in Rhino by default. :slight_smile:

1 Like

Sometimes I need the planar surface to be aligned in order to extract isocurves from it in the correct directions to further use the latter for extrusions or making rectangular hole(s). Also, quite often I split surfaces via their isocurves.

By the way, do you have any idea why rotating a planar surface with your script produces naked edges around it? the workaround is to extract it and then join it again. :slight_smile:

1 Like

Probably something dumb - I’ll take a look.
Yep, dumb. @Rhino_Bulgaria - should be fixed, above.

I see why sometimes, for specific tasks, the UV direction might be important; my question is, why the CPlane in particular?


1 Like

because when its fixed to world cplane then you have no option to control it. if its current cplane you can just switch different cplane before running such command thus you have control over your isocurves orientation. so for me most logical is the current cplane…

1 Like

Exactly my point. Having a control over the direction of the cap surface is what makes any further adjustments either possible or a pain to do. This is especially true when control point editing a polysurface. Non-parallel cap surfaces that are then modified that way typically produce weird results and sometimes even bad objects.

Yes, it’s fixed now. :slight_smile: Thanks again, Pascal! This script is really useful.

I see- Thanks… This seems very roundabout to me, the ability to adjust as needed seems like it would be far more useful - am I right about that? If you would be setting a cplane just to control UV on a Cap, you might as well cut to the chase and just be able to control planar UVs in general, as in the script… ?


yes the script is nice, such suboptions in cap command would be nice

Hello - presumably, you’d like me to make a request on the bug tracker. Let me try just one more teenieweenie time to understand : Is the goal to set the direction to the CPlane or is the goal to set the direction any way you want it?


I would like to have the Iso respecting the cplane orientation.
Many students were confused by the MergeallCoplanarFace when the new face doesn’t respect the orthogonality. And I’ve to explain (pointless) things about the fact that isn’t a big issue :wink: .

From my experience isn’t needed to have a customizable direction, but could be an useful advanced options.

1 Like

point is to have the ability to control it but preferably aligned with cplane (default) and with other suboptions such as world or custom dir. similar how your script asks for options …

1 Like

For now, @ivan.galik @Rhino_Bulgaria @skysurfer - I updated the tool above with some more alignment options. The line option will let you select a linear curve (including surface edges, which is the main use of it I wuold think) or pick teo points in space.

I guess this cplane alignment request is for

what else?



Wow, the new changes do something weird now. I uploaded a video to show what’s happening on my model. The older version of the script worked properly on that surface, but the new one seems to make its own funny things with the geometry. :slight_smile:

Couldn’t just work, eh? OK, I’ll have another look.
@Rhino_Bulgaria - I see - I caught that problem here yesterday but apparently after posting ? - if the attached script here does not work right, can you send me an example? (6.9 KB)



Yep, the issue is still there. Maybe it’s specific for this particular model, or because the flat surface is already aligned to the same edge that I try to align to with the script? For some reason the control points move to a totally different location. Here is the model that produced the error:
Rotate cap surface 1.3dm (717.7 KB)

Yeah, if I first modify the direction using the interactive way, then use that edge on a second try, it seems to work as expected. I’ll poke at it… thanks.

Seems to mess up if the slected line is parallel to but opposite U in direction… @Rhino_Bulgaria see if this fixes it and does not break something else… (7.5 KB)

@Rhino_Bulgaria , @ivan.galik @skysurfer A plug-in version - Unblock it in Windows and then drag and drop onto Rhino (7 or later)

PlanarFaceDirection.rhp (17 KB)

@Rhino_Bulgaria - updated both script and plug-in here - I think this fixes the direction problem, but I am not sure it will always get it right.



Thank you for putting your time into this great script, Pascal! It does wonders and already helped me a few times during my recent work days. :slight_smile: