Cap did not succeed in GH but in RH

Hi everyone,
I’m setting up a tiny bolt generator for 3d printing purpose - fully run in GH 7/MacOS.

I decided to generate the thread simply by 2 rails and a section curve. However to create a solid I need to split/crop and cap the sweep surface. (21.0 KB)

May someone help me to understand two issues on this fairly basic op.

  1. When the (z axis) of my cutting object exactly hits 0° or any full rotation of my rails and section curve, the split operation is not working. Why is that so?

  2. I can split and create a bottom and top surface in GH, but can’t create a solid body nor cap. Baking and joining in RH works. Why is that so and what am I missing in GH?

Any help appreciated.

BoltGen is a Rhino plugin, not GH.

1 Like

Hello Joseph,

thank you for the info. I’m well aware of that plugin.

Maybe you also have some idea on how to split and cap the twisted surface in GH rather than baking the geometry and joining it in RH? And why the split does not work when the splitting surface is exactly on the seam?


The sweep doesn’t generate a closed surface. I assume, that this is part of the problem.

I don’t have a solution yet though.

1 Like

Sweep does not automatically join the surfaces.

One way to circumvent this problem is to deconstruct the sweep and join the surfaces.

Then instead of trimming the threads, you can use the Solid Intersection component like this: (15.7 KB)


Is there a smarter way to create this kind of rotating surface?

Linear array just one thread instead maybe?

Ah, nice workaround. Kind of how I did it in on some surfaces in RH. First explode and then rejoin. I will also check on how the surface develops with linear arrays.

Very helpful. THX

I just tried with no success

That’s ok. If the other solution works on several DIN bolts you made my day!

1 Like

Hi Martin,
your solution looked so convenient, but it is not working on my system. Any idea?

Try this. (18.2 KB)

Thanks for the effort! Unfortunately it is always the brep join that is keeping me stuck (arghhh).

It should have worked already with your very first idea. Must be something with the settings or so. I’m getting crazy.

It fails in my Rhino 7 installation too.

The Brep Join result doe not need to be closed. It should however have just two closed naked edges. Somehow this doesn’t seem to work in Rhino 7 unfortunately.

Where did you produce working results? 6 or 8?

PS: To be precise, it’s not working within GH in RH7. Because manual joining surfaces and cap in RH is working fine.

I’m using Rhino 8 (15.2 KB)
Create solid component will solve it
flexibility or Parakeet can be used

Hi Rajeev,
thx for joining the conversation. CreatedSolide seems really handy, but I won’t be able to use it until I Brep Join correct.

list of Brep should go into create solid (not tree)

Forget this brep join c output. The sweeps do not have planar edge loops.

A correct join results in an open brep with two closed edge loops at the naked edges.

Try the script posted here:

This brep join has a tolerance input which might solve the problem.

1 Like