Can't snap to objects behind Clipping Planes in Rhino 8 WIP

Clipping Planes settings for objects/layers in Rhino 8 are awesome, but snapping doesn’t work for objects behind clipping planes when their “Clip” property is set to “None”.

Rhino 8 (8.0.22291.12305, 2022-10-18)

Hi Daniel -
Just wondering - how is this a “Rhino Developer” question? Are you using code to do something?
-wim

Hi, sorry, maybe that’s not the right place to post this, but I thought that this could be considered as a bug? I’d assume that you’d normally want to snap to all visible and active objects irrespective where they are.

If there’s a dedicated to place to send this type of issues already, please let me know.

Hi Daniel -

When you mouse-over a category of an existing thread, there will be a tooltip that shows what the category is for.
image

Bugs that you encounter as a user of Rhino can be posted in the general “Rhino” category.
Issues with or requests for the WIPs are in the “Serengeti” category.

Putting topics in the correct category will ensure that it gets attention of the correct people and makes it easier to find things when searching at some later point.

In a quick test here, I see correct snapping to visible objects on the “wrong” side of a clipping plane but there is no feedback point. When you go to Rhino Options -> Modeling Aids -> Cursor Tooltips and enable Osnap, you should see the tooltip appear when you snap to something -

Is this behaving differently on your side?

As for the point feedback, I filed RH-70920 Display: No point feedback on clipped side of clipping plane
-wim

1 Like

Thanks, makes sense. I’ve changed category for these issues (I couldn’t find Serengeti before).

Thanks for filing the bug as well. Now that you mentioned it I’ve tried hiding everything in the scene and snap to a cube behind a clipping plane like you did and the behavior is the same as you described, but… once I’ve brought back (“Show” command) the rest of my scene the snaps stopped working again (no tooltip, clicking nearby the “End” corner didn’t snap to it). Screenshots below (cursor is hovering over the same place on the second screenshot)

Hi Daniel

Could you please post a file that shows that behavior?
-wim

Sure, please see this file:
test.3dm (884.7 KB)