Can't install Rhino 4 on Windows 8 Asus laptop

Click on CD and bunch of icons appear with language ones on left and three separate ones stacked on right with top and bottom ones no rhino logo and lead to notepad code looking stuff so click on middle one setup with rhino logo. When I click on the icon “setup” window says it’s program name:Setup.exe publisher: unknown it gives me message:
“This installation package could not be opened. Verify that the package exists and that you can access it, or contact the application vendor to verify that this is a valid Windows Installer package.”

It’s a Rhino 4 student copy (got it years ago when taking a course) I never got around to learning but am now with this laptop. I’ve successfully installed it on another Windows 8 laptop last summer or summer before while using my mother-in-laws Dell Windows 8 laptop she never used and removed it so I know it’s worked. I tried installing it on my mac mini with Parallels but I think got same message. Now that I have this PC laptop given to us I’m going to use it for Rhino and get Grasshopper so really need to get this thing going.

Download a fresh V4 full installer from the Download page on the Rhino Web site.
Install using it and your V4 key code.

Make sure your Windows is FULLY up to date with ALL IMPORTANT updates BEFORE you install Rhino.
Since it sounds like it’s a new computer,m you will probably have to run Windows Update multiple times to get all of the IMPORTANT updates installed.

Good luck

Note also that you can only run a very old “legacy” version of Grasshopper in V4. If you want to run a version of Grasshopper that’s less than about 2 years old, you will need V5.


Thanks guys.