Cannot Open Package Manager

Hello there,

I have recently had Rhino 7 installed onto my computer and have never been able to open the Package Manager. I have had the latest update installed and still I cannot open the Package Manager.

I have attached an image of the error.

Could someone please tell me how to resolve it.

Regards,
Scott Viney

Screenshot 2022-03-22 133137

Looks like you may have accidentally changed some of your settings since the address shown in the dialog is pretty much incomplete.

Please post the unchanged esult of the Rhino command _SystemInfo.

Further, in file explorer go to %APPDATA%\McNeel\Rhinoceros\7.0\settings and attach the settings XML file from it here.

Thanks for replying Nathan,

Below is the system info. Not really sure what youre asking me to do in the second part. I have located the directory as shown in the image below but what do you want me to do with what file?

Rhino 7 SR15 2022-2-8 (Rhino 7, 7.15.22039.13001, Git hash:master @ 2833e18992fc4b5cf99bb29c4d8e8add4f02074d)
License type: Commercial, build 2022-02-08
License details: Cloud Zoo

Windows 10.0.19044 SR0.0 or greater (Physical RAM: 32Gb)

Computer platform: LAPTOP - Plugged in [92% battery remaining]

Hybrid graphics configuration.
Primary display: Intel(R) UHD Graphics 630 (Intel) Memory: 1GB, Driver date: 7-9-2021 (M-D-Y).
> Integrated graphics device with 3 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port
- Windows Main Display attached to adapter port #1
Primary OpenGL: NVIDIA GeForce RTX 2060 (NVidia) Memory: 6GB, Driver date: 12-6-2021 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 472.84
> Integrated accelerated graphics device with 4 adapter port(s)
- Secondary monitor is laptop’s integrated screen or built-in port

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On
Graphics level being used: OpenGL 4.6 (primary GPU’s maximum)

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-6-2021
Driver Version: 30.0.14.7284
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.15.22039.13001
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.15.22039.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.15.22039.13001
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.15.22039.13001
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.15.22039.13001
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Drag and drop the settings-Scheme__default.xml file into the text area of the reply you’re going to write. It will upload that file as an attachment to the reply.

settings-Scheme__Default.xml (16.2 KB)

Thanks, that settings file looks all fine. Can you please follow the menus:

Tools > Options > Advanced

Then type source in the text field so that you can see the setting Rhino.Options.PackageManager.Sources? Please take a screenshot of it and its value if it does not look like mine:

If it is different please change the value to what is shown in my screenshot.

Thanks for your time Nathan. Updating that setting to the default has it working now.

Cheers!

Cool! Apparently that setting is not saved in the default settings file. I suppose it goes to one of our core plug-in settings. Anyway, leaves me wondering how you managed to change this value, though…

Have fun using Rhino!