Cannot deselect text object

Here I am, again, with what will not doubt turn out to be more proof that I am a Rhino Idiot. My apologies, in advance. I have tried to find a solution on the Forum and in Google but cannot come up with search terms that work.
Occasionally, when I create a new text object, using the “text” command, I can place the new text but then cannot move it or deselect it. i can’t even delete it. It’s as if Rhino does not know that the object exists. If I type the copy command, for example, Rhino asks me to select objects to copy. I can select other objects and deselect them. The only way to fix the problem is to save the drawing and open it, again.
Here’s what may (or may not) be a hint. When I open the drawing, without closing it first, the text is there and can be selected and deselected, moved, etc. However, it is not sized correctly. It is at the default size. I changed the size of the text right after creating it. It is possible that this broke the text in some way.
I cannot recreate this. It just happens, seemingly at random.
Again, my apologies. I can’t wait to find out how dumb I am being.

Hello - I don’t think you are being dumb, off hand this sounds like a bug … is the text resized larger when you resize it? And will it select if you click in the area occupied by the original sized text?


I cannot access the text unless I restart Rhino. I can select everything else. If I Ctrl-A, everything selects, then I can mouse-click in blank space and everything deselects… except the text. No, I do not have any layers set to use yellow as a color.
As I mentioned, if I open a new instance of the drawing (read only, of course) I can select and manipulate the text, normally. However, it is not the same size as in the “troubled” instance and it is out of position, but I can change the size and move the text.

Is there a command that will refresh the entire drawing, or is that the same as closing and opening the drawing? I guess I am wondering if this is a graphics issue or a code issue.

OK - what I was wondering is, if you place the original text just inside a rectangle, say,. and then after resizing the text, click inside the rectangle - does the text select?
Can you send me a file that has one of these?


I can’t do anything with the original text. It’s just selected and stays that way. Do you mean after I close and reopen it?

I see, so SelNone does not un-highlight it?

@Gizmobreaker - what are your settings in Options > Mouse page > Selecting? Does messing with the middle two checkboxes do anything to change the behavior?



Perhaps you can crossing window select the text and run the BoundingBox command.
There have been a few issues with text and resizing where the bounding box was not recalculated. The text can only be selected within in it’s bounding box.

Bounding box does not work because Rhino thinks nothing is selected. If I try to select the text, it does not recognize that I selected anything. The text remains yellow, all the time.

No luck with Mouse Options, either. I also tried F10 but that does not turn on control points for this text object. F11, of course, doesn’t do anything, either.

If I do a Zoom - Objects, Rhino returns “Unable to zoom - no objects are selected.”

Sorry, Zoom - Selected.

hm… can you make a file that has one or more of these bad guys in it and post it here or send to


Of course. But it will then be normal. If I close and open the drawing, it will be restored. I’m going to send it to you, anyway. I’m also going to print viewport to a pdf to see if the text shows in that file.

Interesting. The text does not show in the Print dialog preview pane.

I sent the files. I was able to do a screen grab that shows the yellow (selected) text. When I printed from Rhino 6, however, the text is not visible. If you open the Rhino file, you should see the text slightly above where it is on the screen grab, and smaller.

Thanks, I have the files - what is the process, exactly, when you make the text?

So as placed the text follows the annotation style and is 1.5 units high, (.125 * 12x model space scaling) is that correct? Then what? Do you scale the text (Scale or Gumball) or do you set the size? To what?


I type “text” which opens the text dialog. I enter the text, there. I click OK and position the text. Then I select the text and set the size in the text dialog. The text changes size. Then I tried to move it. No luck. After that it just stayed yellow but I could not access the object in any way.

Yes, it is .125 x 12x. I only changed the height to .25. No change to model space scaling.