Cannot Change "WHAT" Dimensions

On a roll here tonight:

Rhino is in a state where the WHAT command is disconnected from the file settings such that it displays measurements in feet-inches, regardless of what I put in the project settings.

Restarting Rhino and Rebooting did not fix the problem.

Properties>Details displays according to the project settings and gives a different result than WHAT does.

How can I get out of that one?

What option is Distance Display set for? In the file you recently upload it is set for Feet & Inches:

Document Properties > Units > Model

Right now “it” is set to decimal. I can set it to fractional with no change. However, it happens with all files.

Properties>Details:

WHAT:

Hello - - that does look buggy - as far as I know those should put up the exact same dialog. I’ll check, thanks.

-Pascal

This has been puzzling to me. Here is the settings (fractional):

The WHAT command does (feet/inches):

Details does (decimal):

So they both appear disconnected from the settings. Could this be something in the RHINO configuration that has gotten screwed up? Apparently, I am the only one seeing this.

I was wondering if anyone has any ideas on this one?

It is really annoying.

There must be some way to reset this.

Hello - you’re not the only one seeing it - I can confirm they do not match, I’ll get it on the bug pile, thanks.
Well, not quite - the resolution in What does seem to correspond, so far, to file settings.

-Pascal

My thought has been that a configuration file has been corrupted somehow.

Any how that that will get fixed soon?

It is a major PITA not to be able to get the dimension of a line.

Hello- Length ought to help here.

-Pascal

Except that Length does not give Fractional dimensions or, if it does, it has the same problem.

:frowning:

Hm - Length follows the file settings here -

e.g: Length = 8’10-1/4"

-Pascal

Hello- that does not happen here - shot in the dark… do you by chance have testNumberFormat set to ‘accurate’? I think not, you’d gen even more zeros, but just in case.

-Pascal

Set to PRETTY

@BrianJ - does this seem like a ‘reset pList’ sort of thing? So far I cannot repeat in the latest, I’ll try 7.10/11

-Pascal