Can Linewidth in Plan Views match those in the model?


(Djhg) #1

My Plan Views are coming in with fills reflecting layer settings in Wall Styles, and line types are reflecting line types and scales in the model, but line widths are all displaying and printing at the default width.

  1. Is there any way to get line widths in Plan Views to print the same variety of line widths as the Model (besides exploding the Plan Views, which works.)
  2. Failing 1, is there any way to control what linewidth all the lines in the Plan Views print?

#2

@djhg,

  1. Lineweights of 2D geoemtry in 2D Plan views should be the same as the 3D model shown in plan view. Please attach a model where this behaves differently.
  2. The lineweights of 2D geometry in plan views are those asigned to the 3D objects the 2D geometry represents. You could overwrite this setting by changing the print width of the plan view style, but this is not currently working. So in the meantime you will need to edit the print widths on 3D object and update the plan views.

(Djhg) #3
  1. Never for me, neither when first created nor with any number of settings adjustments. (Not unless they’re exploded) I’ve uploaded the file and sent you a link.
  2. (See number 1)
  3. This is new but related: The Plan View in that detail window doesn’t respond to changes in the default line weight setting in the print window. (Nor to scaling. The dimensions, which aren’t part of the plan, do respond to scaling.) They respond - both print and display - to changed in pixel display width for curves in Options>WIreframe>Curves, but that adjustment is too coarse; it will only double or triple them. I don’t know what they are printing at, but they’re too thin - they appear to be hairline.

#4
  1. In the model you sent me (“PlanViewDefaultLinewidths”) there is no Plan view created. If I create one, I don’t see any difference of lineweights between the Model with the
    Cut Plane on or a 2D plan View. Can you update the model and point me out which lines look different in thickness?
  2. What do you mean by “in the Print window”? Detail viewport? Print Setup dialog? And what do you mean by “nor to scaling”? the Plan view Scale property? The Detail scale? I’ll wait for the new model to check this out.

(Djhg) #5

One) I thought it best if you generated the Plan View on your system for testing purposes. But I’ll upload another one with one I generated. The difference is there on my system when I generate one. Here’s a snapshot. It’s the door in this shot. (Wireframe Top-Ground View, Model below, Plan View outlined in green above):


On another version of this project the door became the matching lineweight if I exploded the Plan View, but that doesn’t fix it in this version for some reason.

Three) Please let me know how best to print with a larger default line thickness so I can work around the above problem (unless we can fix it). This adjustment (in Print Setup) doesn’t have any effect on Line Widths printed from a Plan View) no matter which of the setting options shown are changed.:
PrintSetupForLineWidths


#6

@djhg I see the issue now! It looks like a bug when printing objects in section (in Wireframe it doesn’t print the door in the right line width. In Hidden there is a mixture of line widths.)
I’ll get back to this post when we fix that.


(Djhg) #7

Yes, thanks, but do you have a recommendation for how to change the default line thickness display of these elements? They aren’t responding.


#8

What you can do while we fix this is to create a plan view (vaPlanView command) or Section View (vaSectionView command), and print them rather than the 3D model in section.


(Djhg) #9

That’s where the problem I am asking about is, Francesc. With Plan Views and Section Views. I guess I haven’t explained clearly enough - though I thought i had - that it’s those views vaPLanView and vaSectionView that don’t display line widths at the moment. (And the Views of the Model have unworkable problems which I appreciate you acknowledge.) This is why I keep asking how to adjust the default line widths for vaArq objects, because if that’s not available, given the other limitations, everything from VisualArq used as a documentation tool has to have the ulttra-fine default width.


#10

Try to explode the vaPlanViews and vaSectionViews and print them in Wireframe display mode while we fix these issues. Those objects that had the linewidth set to “Default” should take the “default line width” from printing settings.


(Djhg) #11

I keep trying this, but it has only worked one time.

Does this work for you with Plan Views, Francesc? Even if exploded? Consistently? On my system it only works consistently on curves created in Rhino but, as I have said, it has never worked on the many lines which are generated in a Va Plan View yet retain the default line width irrespective of their settings. That is why I have asked if there is another way. If that is the only way to do this, then - at least on my system, which is quite new - the factory default Rhino linewidth is unfortunately VisualArq’s only reliable line width.

Every object exploded has its linewidth set by object to “default,” and Wall fills all become black also. My tests with the Savoie model, 2 versions of Va ago, the line widths were restored when exploded, but those projects now explode to default linewidths. Maybe this has been lost with recent revisions. It’s a significant loss.


#12

Yes, it does.
After exploding a plan view, the 2d lines keep the attributes of the 3D objects they represent, including print widths:


(Djhg) #13

Today it’s working for me also.
Thanks…
It may be that the multi-step activation of PrintDisplay (S>Enter>O>Enter>Enter) isn’t getting fully activated and the Print Setup > Linetypes and Line Widths > was set to Match Viewport.
If that’s what it was (I hope so) sorry for all the above.


(Djhg) #14

And today it’s working even with the Plan Views unexploded.
I seem to recall experiencing inconsistency printing from Layout Space from Make2D objects. Maybe I wasn’t savvy to the Pattern/Viewport Matching in PrintSetup. But it was confirmed by the Rhino DevTeam at the time. THere may be more going on here than my own neglect of those setting, or maybe not. I’ll keep watching out for it, because it’d be great to retain line width settings without exploding.


#15

Thanks for these updates. We will keep on working from our side to provide a good printing results either with the model in section (in HIdden display mode) as from unexploded 2D plan and section views.


(Djhg) #16

That’d be preferable. I understand that Make2D and the Views are destined for obsolence, but I hope that doesn’t happen until these sorts of things are resolved. On the Rhino side of things, resolving occlusion from meshes is going to be quite thorny, I think. It wasn’t even close to working on my most recent (and quite convoluted) Rhino objects.