Can Bongo Video Texture accept Image sequences with Alpha Channel?

Hi, I have been trying to load image sequences into the Bongo Video texture and it doesn’t seem to work.
I am hoping that the video texture will show the transparency from the image Alpha layer (in TGA, PNG,Tif image sequences )

@Mike_A - The Bongo Video texture will not load a file sequence and make it into a video for you. The Bongo Video texture supports avi, mpg, mpeg, ogv and wmv as moving images formats.

Thanks Marika,
Which is the best movie format to use that can show Alpha Channel Transparency ?
ie .AVI+Codec for Alpha Channel ?
Regards,
Mike.

@Mike_A - I’ll correct my last post - The Bongo Video Texture can also accept numbered sequential frames. So if it doesn’t work, please make sure you have the files you input named correctly so they are sequentially numbered at the end.

I am generating the image sequence in Adobe After Effects, the images have the correct number sequences.
I have used this method in 3Ds Max thousands of times…I know it works.
I have already paid for Bongo so I guess I will have to persist with it until you get a stable version.

Sorry, the Bongo image sequence function simply doesn’t work, but I have found the correct AVI+ Codec combination for Alpha channel transparency for video textures out of After Effects.

Can you provide the sequence and model for us please? You can reach me at joshua@mcneel.com

https://www.rhino3d.com/upload

No, but I will upload the finished video.
Sorry, I have lost days of progress on this video due to poor product knowledge from you guys.

That is if I can even get it to render out a very basic animation…
I reopen the same file and try to get a render out and Rhino crashes.
I restart the machine, try again and Rhino crashes.
I have been using Rhino for 20 years and I am very disappointed with Bongo.

What renderer are you using? What version of Bongo and what version of Rhino?

It’d also help if we can get the model or more information about the sequence or video you’re using for the video texture. That way we can attempt to reproduce and help you resolve this issue.

I am using the latest versions of Rhino and Bongo and the current Rhino renderer.
I also tried the Bongo WIP, same problem.
If I try to load an image sequence it just uses the first frame, not the whole sequence. Is there a tick box somewhere to say “use entire sequence” (Similar to AfterEffects) ?.Also, why is there a tick box for “Alpha Transparency” under the Material Properties Advanced settings, but you still have to choose the transparent colour under the Bongo Video Texture settings ?

Please post the result of the Rhino command _SystemInfo to help me figure out why Rhino Render crashes for you on your machine.

Rhino 7 SR3 2021-2-8 (Rhino 7, 7.3.21039.11201, Git hash:master @ 7bcc02a54515376cb2bd3d05f62d9473ab4bc38c)
License type: Commercial, build 2021-02-08
License details: Cloud Zoo

Windows 10.0.19042 SR0.0 or greater (Physical RAM: 64Gb)

Computer platform: DESKTOP

Standard graphics configuration.
Primary display and OpenGL: NVIDIA GeForce RTX 2060 (NVidia) Memory: 6GB, Driver date: 12-31-2020 (M-D-Y). OpenGL Ver: 4.6.0 NVIDIA 461.09
> Accelerated graphics device with 4 adapter port(s)
- Windows Main Display attached to adapter port #0

OpenGL Settings
Safe mode: Off
Use accelerated hardware modes: On
Redraw scene when viewports are exposed: On

Anti-alias mode: 4x
Mip Map Filtering: Linear
Anisotropic Filtering Mode: High

Vendor Name: NVIDIA Corporation
Render version: 4.6
Shading Language: 4.60 NVIDIA
Driver Date: 12-31-2020
Driver Version: 27.21.14.6109
Maximum Texture size: 32768 x 32768
Z-Buffer depth: 24 bits
Maximum Viewport size: 32768 x 32768
Total Video Memory: 6 GB

Rhino plugins that do not ship with Rhino
C:\Program Files\Bongo 3.0 (64-bit)\Rhino6\Bongo.30.rhp “Bongo 3.0”
C:\Program Files\Veesus Arena4D For Rhino 6\Arena4D.rhp “Arena4D” 2.4.0.0
C:\Program Files\Bongo 3.0 (64-bit)\BongoUI.30.v60.rhp “BongoUI30v40”

Rhino plugins that ship with Rhino
C:\Program Files\Rhino 7\Plug-ins\Commands.rhp “Commands” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\rdk.rhp “Renderer Development Kit”
C:\Program Files\Rhino 7\Plug-ins\RhinoRenderCycles.rhp “Rhino Render” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\rdk_etoui.rhp “RDK_EtoUI” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\rdk_ui.rhp “Renderer Development Kit UI”
C:\Program Files\Rhino 7\Plug-ins\NamedSnapshots.rhp “Snapshots”
C:\Program Files\Rhino 7\Plug-ins\RhinoCycles.rhp “RhinoCycles” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\Toolbars\Toolbars.rhp “Toolbars” 7.3.21039.11201
C:\Program Files\Rhino 7\Plug-ins\3dxrhino.rhp “3Dconnexion 3D Mouse”
C:\Program Files\Rhino 7\Plug-ins\Displacement.rhp “Displacement”

Hi,

Are you animating the frame number?

You can do this by pressing the animate button, moving the timeline slider to a different tick, and then changing the frame number. Now when you move the timeline the video texture will update. You should see a new keyframe when you do this.

image

Yes.

I’m running out of ways to help without a model and the sequence of images/video. If you send it to me via the upload link the model is kept completely confidential. It would definitely help me track down and resolve any bugs/issues in Bongo.

https://www.rhino3d.com/upload?to=joshua@mcneel.com

Hi, I think the problem is due to the Codec used in the Bongo Video Texture. I have found a combination which seems to work. Can you please answer my previous questions below.
""If I try to load an image sequence it just uses the first frame, not the whole sequence. Is there a tick box somewhere to say “use entire sequence” (Similar to AfterEffects) ?.Also, why is there a tick box for “Alpha Transparency” under the Material Properties Advanced settings, but you still have to choose the transparent colour under the Bongo Video Texture settings ? “”

Hi Mike,

There’s a known issue with certain codecs and the AVI format. It’s logged here.

There is no “Use Entire Sequence” or equivalent check box in Bongo. In Bongo the playback of the video texture is controlled by animating the frame number of the video/sequence. If you need more details you can look at my previous post. Looking more closely it’s a bit odd that you don’t see what the number of frames is when setting that value. I’ve logged this issue as a request to make that easier. I’ll try to incorporate that improvement into Bongo 3.

The transparent color for the video texture is for color keying. It works just like a green screen where you specify the color to be keyed out and made transparent.

Well, I am glad that I have solved the codec issue that you have.
I get a "404’’ when I try to check out your Frame number issue link.
Why do you need colour keying when the video texture AVI /sequence has an Alpha Channel ??
If I have checked the "Use Alpha"checkbox, why do I still need to choose a transparent colour ?
The Alpha channel provides the transparency.

Sorry, I forgot to make the issue public. It’s fixed now.

The need for the transparency color is odd. I didn’t notice this before. I’ll log a bug but it shouldn’t behave that way. I’ve logged that here.